Bug 885217 - no login screen in f18 beta after update
Summary: no login screen in f18 beta after update
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 18
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-07 19:37 UTC by RudraB
Modified: 2013-01-16 15:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-02 21:52:00 UTC


Attachments (Terms of Use)
journalctl -b output (69.89 KB, application/octet-stream)
2012-12-08 20:02 UTC, RudraB
no flags Details
Xorg.0.log.old (37.29 KB, application/octet-stream)
2012-12-10 16:04 UTC, RudraB
no flags Details
/etc/hostname (7 bytes, application/octet-stream)
2012-12-10 20:20 UTC, RudraB
no flags Details
/etc/sysconfig/network (60 bytes, application/octet-stream)
2012-12-10 20:21 UTC, RudraB
no flags Details
/etc/hosts (83 bytes, application/octet-stream)
2012-12-10 20:22 UTC, RudraB
no flags Details
xorg.0.log from first boot (39.34 KB, application/octet-stream)
2012-12-11 21:36 UTC, RudraB
no flags Details

Description RudraB 2012-12-07 19:37:56 UTC
Description of problem:
After doing a fresh installation of f18-beta from live-dvd, I run "yum update" and reboot the machine. Machine did boot, but no login screen.
same as https://bugzilla.redhat.com/show_bug.cgi?id=170873

Version-Release number of selected component (if applicable):
f18-beta

How reproducible:

Steps to Reproduce:
1. Do a fresh installation
2. yum update
3. reboot
  
Actual results:
machine stops at full-blown fedora logo, no login screen

Expected results:
Login screen should appear

Additional info:
uname -a
Linux localhost.localdomain 3.6.6-3.fc18.x86_64 #1 SMP Mon Nov 5 16:26:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I dont know which file I should attach, please ask.

Comment 1 RudraB 2012-12-08 18:47:17 UTC
As in the bug report 170873, I generated a xorg.conf, which loads glx only *almost* solves the problem, except I am in a basic graphics mode, where I cannot view full screen movies.
I have:

lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)

and 

 rpm -qa|grep xorg
xorg-x11-drv-vmware-12.0.2-3.20120718gite5ac80d8f.fc18.x86_64
xorg-x11-utils-7.5-7.fc18.x86_64
xorg-x11-drv-intel-2.20.14-1.fc18.x86_64
xorg-x11-font-utils-7.5-9.fc18.x86_64
xorg-x11-xinit-1.3.2-7.fc18.x86_64
xorg-x11-drv-fbdev-0.4.3-3.fc18.x86_64
xorg-x11-proto-devel-7.6-24.fc18.noarch
xorg-x11-drv-mga-1.6.1-2.fc18.x86_64
xorg-x11-server-common-1.13.0-11.fc18.x86_64
xorg-x11-drv-qxl-0.1.0-1.fc18.x86_64
xorg-x11-xauth-1.0.7-2.fc18.x86_64
xorg-x11-drv-wacom-0.16.1-2.fc18.x86_64
xorg-x11-drv-evdev-2.7.3-2.fc18.x86_64
abrt-addon-xorg-2.0.19-2.fc18.x86_64
xorg-x11-drv-synaptics-1.6.2-7.fc18.x86_64
xorg-x11-drv-openchrome-0.3.1-1.fc18.x86_64
xorg-x11-server-utils-7.5-14.fc18.x86_64
xorg-x11-drv-nouveau-1.0.4-1.fc18.x86_64
xorg-x11-server-Xorg-1.13.0-11.fc18.x86_64
xorg-x11-xkb-utils-7.7-4.fc18.x86_64
xorg-x11-drv-vmmouse-12.9.0-7.fc18.x86_64
xorg-x11-drv-modesetting-0.4.0-4.fc18.x86_64
xorg-x11-drv-ati-7.0.0-0.8.20121015gitbd9e2c064.fc18.x86_64
xorg-x11-drv-vesa-2.3.2-2.fc18.x86_64

Comment 2 RudraB 2012-12-08 20:02:25 UTC
Created attachment 660013 [details]
journalctl -b output

Comment 3 Ray Strode [halfline] 2012-12-10 15:21:49 UTC
can you move the system back to the more broken configuration, then grab /var/log/Xorg.0.log and attach it here?

Comment 4 RudraB 2012-12-10 16:04:03 UTC
Created attachment 660937 [details]
Xorg.0.log.old

Comment 5 RudraB 2012-12-10 16:05:44 UTC
Xorg.0.log.old is the log for broken system, i.e., without the xorg.conf

Comment 6 Ray Strode [halfline] 2012-12-10 19:23:40 UTC
oh wait, i think i know what this is:

> Dec 08 19:43:00 roddur gdm-simple-slave[1005]: WARNING: Failed to give slave programs access to the display. Trying to proceed.

http://git.gnome.org/browse/gdm/commit/?id=0fccf4e0671e49

Comment 7 RudraB 2012-12-10 19:33:23 UTC
So, can I do anything right now, or should I wait for the next update?

Comment 8 Ray Strode [halfline] 2012-12-10 19:36:34 UTC
(btw, i think this manifested as a side effect of bug 875085 that was later fixed by bug 831735, but i'll push the GDM fix too)

Comment 9 Ray Strode [halfline] 2012-12-10 19:43:56 UTC
can you attach /etc/hostname /etc/sysconfig/network and /etc/hosts and the output of 

$ host roddur

?

Comment 10 RudraB 2012-12-10 20:20:09 UTC
Created attachment 661090 [details]
/etc/hostname

Comment 11 RudraB 2012-12-10 20:21:13 UTC
Created attachment 661098 [details]
/etc/sysconfig/network

Comment 12 RudraB 2012-12-10 20:22:22 UTC
Created attachment 661100 [details]
/etc/hosts

$ host roddur
Host roddur not found: 3(NXDOMAIN)

Comment 13 RudraB 2012-12-11 21:36:09 UTC
Created attachment 661695 [details]
xorg.0.log from first boot

xorg.0.log from first boot attached! Cant find out what is making the difference.

Comment 14 Ray Strode [halfline] 2012-12-11 22:15:33 UTC
what's the output of

rpm -q NetworkManager

?

Comment 15 RudraB 2012-12-11 23:10:34 UTC
$ rpm -q NetworkManager
NetworkManager-0.9.7.0-9.git20121004.fc18.x86_64

Comment 16 Fedora Update System 2012-12-20 17:03:30 UTC
gdm-3.6.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20593/gdm-3.6.2-4.fc18

Comment 17 Fedora Update System 2012-12-20 17:48:41 UTC
gdm-3.6.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gdm-3.6.2-5.fc18

Comment 18 RudraB 2012-12-20 23:39:52 UTC
Problem is still there!!
rpm -qa|grep gdm
pulseaudio-gdm-hooks-2.1-4.fc18.x86_64
gdm-3.6.2-5.fc18.x86_64
gdm-libs-3.6.2-5.fc18.x86_64
gdm-debuginfo-3.6.2-5.fc18.x86_64

Comment 19 RudraB 2012-12-20 23:49:21 UTC
btw, if you find important, I am still using default hostname:
$ hostname
localhost.localdomain
$ host localhost
localhost has address 127.0.0.1
localhost has IPv6 address ::1

Comment 20 Fedora Update System 2012-12-21 01:33:03 UTC
Package gdm-3.6.2-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdm-3.6.2-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20736/gdm-3.6.2-5.fc18
then log in and leave karma (feedback).

Comment 21 RudraB 2012-12-21 02:32:15 UTC
I have this version installed, as shown in the message 18, without any result

Comment 22 RudraB 2012-12-21 15:33:33 UTC
uhu!! its working! I need to download iso image afresh(may be the iso released with beta had some other bug?), and now its working completely, including https://bugzilla.redhat.com/show_bug.cgi?id=812624 (https://bugzilla.redhat.com/show_bug.cgi?id=812624#c24)

Comment 23 Fedora Update System 2013-01-02 21:52:02 UTC
gdm-3.6.2-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2013-01-11 23:34:03 UTC
gdm-3.6.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 RudraB 2013-01-12 10:45:34 UTC
gdm-3.6.2-5 is not the aboslute answer of the problem I suppose.
I reinstalled f18-RC1 and found the same problem persist. 
The problem is solved when I update my system enabling updates-testing.

Though I dont have the knowledge to let you know which actual package solved the problem, I report it for your knowledge.

Comment 26 spital 2013-01-12 15:28:56 UTC
the same with me - installed Fedora 18 Beta i686 Live Desktop (accepted my fate).
yum update
reboot
and no login prompt - blue backgroud image only.

Can not say what exactly helped - but it is working now.

yum --enablerepo=updates-testing update
shutdown
disabled 3D accelereation in VMware
boot -> init 3
X -configure # some error
cp xorg.conf.new xorg.conf
remove all ScreenX except Screen0 from "ServerLayout" 
cp xorg.conf /etc/X11/
telinit 5

It seems like MATE works, Sugar works, Cinnamon works, KDE has broken dependencies 

this helped:
yum downgrade mysql-libs qt xmlrpc-c xmlrpc-c-c++ qt-x11
yum install @kde-desktop

Comment 27 Gunnar Wagenknecht 2013-01-16 15:49:49 UTC
I upgraded my system from F17 to F18 today using the steps provided here:
https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.3E_Fedora_18

The only thing I have is a blue background image only (no login possibility).

---
# systemctl status gdm.service
gdm.service - GNOME Display Manager
          Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled)
          Active: active (running) since Wed, 2013-01-16 16:39:09 CET; 20s ago
        Main PID: 3313 (gdm-binary)
          CGroup: name=systemd:/system/gdm.service
                  ├ 3313 /usr/sbin/gdm-binary
                  ├ 3333 /usr/libexec/gdm-simple-slave --display-id /org/gnome/DisplayManager/Displays/_0
                  ├ 3341 /usr/bin/Xorg :0 -background none -verbose -auth /var/run/gdm/auth-for-gdm-FpoRBM/database -seat seat0 -nolisten tcp vt1
                  └ 3356 gdm-session-worker [pam/gdm-launch-environment]

Jan 16 16:39:09 FOO systemd[1]: Starting GNOME Display Manager...
Jan 16 16:39:09 FOO systemd[1]: Started GNOME Display Manager.
Jan 16 16:39:10 FOO gdm-simple-slave[3333]: WARNING: Failed to give slave programs access to the display. Trying to proceed.


# grep '(EE)' /var/log/X*
/var/log/Xorg.0.log:    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.0.log.old:        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

Comment 28 Gunnar Wagenknecht 2013-01-16 15:59:20 UTC
Got it working:

--> disabled 3D accelereation in VMware


Note You need to log in before you can comment on or make changes to this bug.