Bug 885275 - Spacing messed up after downgrade to liberation1
Spacing messed up after downgrade to liberation1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
: 885370 885371 885387 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-07 21:23 EST by Pete Walter
Modified: 2012-12-11 00:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 00:59:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing liberation1 spacing issues (6.77 KB, image/png)
2012-12-07 21:23 EST, Pete Walter
no flags Details
liberation 1.07.2-6.fc17 (154.05 KB, image/png)
2012-12-08 10:27 EST, Kamil Páral
no flags Details
liberation 1.07.2-11.fc18 (150.14 KB, image/png)
2012-12-08 10:27 EST, Kamil Páral
no flags Details

  None (edit)
Description Pete Walter 2012-12-07 21:23:44 EST
Created attachment 659668 [details]
Screenshot showing liberation1 spacing issues

With latest Fedora 18 update, liberation-fonts was downgraded from 2.00.1 to 1.07.2. This has introduced unreadable fonts, with too small spacing between glyphs.
Comment 1 Kamil Páral 2012-12-08 10:27:25 EST
Created attachment 659857 [details]
liberation 1.07.2-6.fc17

I see this problem with Mozilla Bugzilla and Fedora Updates. Lots of pages are OK, some are not.

If I install fc17 liberation fonts, everything looks OK. If I update to fc18 version, it is broken.
Comment 2 Kamil Páral 2012-12-08 10:27:43 EST
Created attachment 659858 [details]
liberation 1.07.2-11.fc18
Comment 3 Pravin Satpute 2012-12-09 23:11:33 EST
Ok, i got the problem. This is happening because of 30-0 conf file of liberation-sans-narrow. Building it now.
Comment 4 Akira TAGOH 2012-12-09 23:35:37 EST
Pravin, why are you going to override the metric aliases rules with the own one? it's actually the duplicate rules in fontconfig and never ever had in old liberation1.
Comment 5 Fedora Update System 2012-12-10 00:12:07 EST
liberation-fonts-1.07.2-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-12.fc18
Comment 6 Pravin Satpute 2012-12-10 00:13:48 EST
- Was trying to match with Fedora packaging guideine. Its basic fontconfig file.

- Actually priority was problem. Corrected it now. It is now 59 so fontconfig latin file will override it anyway.
Comment 7 Pravin Satpute 2012-12-10 00:16:14 EST
*** Bug 885371 has been marked as a duplicate of this bug. ***
Comment 8 Pravin Satpute 2012-12-10 00:21:08 EST
*** Bug 885387 has been marked as a duplicate of this bug. ***
Comment 9 Pravin Satpute 2012-12-10 23:58:21 EST
*** Bug 885370 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-12-11 00:59:21 EST
liberation-fonts-1.07.2-12.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.