Bug 885387 - fc-match now matches Sans to Liberation Sans Narrow
fc-match now matches Sans to Liberation Sans Narrow
Status: CLOSED DUPLICATE of bug 885275
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-08 19:49 EST by Jean-François Fortin Tam
Modified: 2012-12-10 00:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 00:21:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (216.85 KB, image/png)
2012-12-08 19:49 EST, Jean-François Fortin Tam
no flags Details

  None (edit)
Description Jean-François Fortin Tam 2012-12-08 19:49:05 EST
Created attachment 660166 [details]
screenshot

Yesterday's updates (not sure which, but I suppose fontconfig was updated among them) make "fc-match Sans" return:

LiberationSansNarrow-Regular.ttf: "Liberation Sans Narrow" "Regular"

It used to return:

DejaVuSans.ttf: "DejaVu Sans" "Book"

It would probably make more sense if it would match for Liberation Sans, not Liberation Sans Narrow. Otherwise, as the attached screenshot shows, this breaks the Internets.
Comment 1 Akira TAGOH 2012-12-09 21:04:16 EST
the package version of fontconfig, liberation-*-fonts, dejavu-*-fonts, and your locale information please.

at least it works for me:

$ rpm -qa dejavu-*-fonts liberation-*-fonts fontconfig | sort
dejavu-sans-fonts-2.33-4.fc18.noarch
dejavu-sans-mono-fonts-2.33-4.fc18.noarch
dejavu-serif-fonts-2.33-4.fc18.noarch
fontconfig-2.10.2-1.fc18.x86_64
liberation-mono-fonts-2.00.1-4.fc18.noarch
liberation-narrow-fonts-1.07.2-10.fc18.noarch
liberation-sans-fonts-2.00.1-4.fc18.noarch
liberation-serif-fonts-2.00.1-4.fc18.noarch

$ fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
Comment 2 Jean-François Fortin Tam 2012-12-09 23:13:35 EST
Hi Akira, here's the info you requested:

$ rpm -qa dejavu-*-fonts liberation-*-fonts fontconfig | sort
dejavu-sans-fonts-2.33-4.fc18.noarch
dejavu-sans-mono-fonts-2.33-4.fc18.noarch
dejavu-serif-fonts-2.33-4.fc18.noarch
fontconfig-2.10.2-1.fc18.i686
fontconfig-2.10.2-1.fc18.x86_64
liberation-mono-fonts-1.07.2-11.fc18.noarch
liberation-narrow-fonts-1.07.2-11.fc18.noarch
liberation-sans-fonts-1.07.2-11.fc18.noarch
liberation-serif-fonts-1.07.2-11.fc18.noarch

$ fc-match sans:lang=en
LiberationSansNarrow-Regular.ttf: "Liberation Sans Narrow" "Regular"

$ env|grep -i utf
LC_MONETARY=fr_CA.utf8
LC_NUMERIC=fr_CA.utf8
LANG=fr_FR.utf8
GDM_LANG=fr_FR.utf8
LC_MEASUREMENT=fr_CA.utf8
LC_TIME=fr_CA.utf8

(not sure what else to provide as "locale information")
Comment 3 Akira TAGOH 2012-12-09 23:48:53 EST
Well, this is due to /etc/fonts/conf.d/30-0-liberation-narrow.conf. it appears earlier than 57-dejavu-*.conf or 45-latin.conf anyway. reassigning.

For reference of our fonts policy:
https://fedoraproject.org/wiki/Fontconfig_packaging_tips#Choosing_a_ruleset_numeral_prefix

just FYI for liberation-fonts maintainer.
Comment 4 Pravin Satpute 2012-12-10 00:21:08 EST
hmm, bad mistake. Happened while merging liberation-narrow-fonts with liberation-fonts.

Fixed priority. it is not 59-

Closing as a duplicate of 885275

*** This bug has been marked as a duplicate of bug 885275 ***

Note You need to log in before you can comment on or make changes to this bug.