Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 885315 - [abrt] python-boto-2.5.2-1.fc17: auth.py:440:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
[abrt] python-boto-2.5.2-1.fc17: auth.py:440:get_auth_handler:NoAuthHandlerFo...
Status: CLOSED DUPLICATE of bug 821799
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
abrt_hash:9c6833a60c26819ca8615f339d4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-08 10:15 EST by Josep Sanz
Modified: 2013-04-05 04:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-05 04:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: executable (13 bytes, text/plain)
2012-12-08 10:15 EST, Josep Sanz
no flags Details
File: environ (3.75 KB, text/plain)
2012-12-08 10:15 EST, Josep Sanz
no flags Details
File: smolt_data (3.00 KB, text/plain)
2012-12-08 10:15 EST, Josep Sanz
no flags Details
File: core_backtrace (514 bytes, text/plain)
2012-12-08 10:15 EST, Josep Sanz
no flags Details

  None (edit)
Description Josep Sanz 2012-12-08 10:15:44 EST
Version-Release number of selected component:
python-boto-2.5.2-1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python /usr/bin/lss3 --help
kernel:         3.6.9-2.fc17.x86_64

backtrace:
:auth.py:440:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
:
:Traceback (most recent call last):
:  File "/usr/bin/lss3", line 71, in <module>
:    s3 = boto.connect_s3()
:  File "/usr/lib/python2.7/site-packages/boto/__init__.py", line 118, in connect_s3
:    return S3Connection(aws_access_key_id, aws_secret_access_key, **kwargs)
:  File "/usr/lib/python2.7/site-packages/boto/s3/connection.py", line 167, in __init__
:    suppress_consec_slashes=suppress_consec_slashes)
:  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 525, in __init__
:    host, config, self.provider, self._required_auth_capability())
:  File "/usr/lib/python2.7/site-packages/boto/auth.py", line 440, in get_auth_handler
:    'Check your credentials' % (len(names), str(names)))
:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
:
:Local variables in innermost frame:
:total_handlers: 1
:checked_handlers: [<class 'boto.auth.HmacAuthV1Handler'>]
:provider: <boto.provider.Provider object at 0x7fe1a4d46290>
:host: 's3.amazonaws.com'
:handler: <class 'boto.auth.HmacAuthV1Handler'>
:names: ['HmacAuthV1Handler']
:ready_handlers: []
:requested_capability: ['s3']
:auth_handlers: [<class 'boto.auth.HmacAuthV1Handler'>]
:config: <boto.pyami.config.Config instance at 0x7fe1a4d419e0>
Comment 1 Josep Sanz 2012-12-08 10:15:48 EST
Created attachment 659853 [details]
File: executable
Comment 2 Josep Sanz 2012-12-08 10:15:50 EST
Created attachment 659854 [details]
File: environ
Comment 3 Josep Sanz 2012-12-08 10:15:53 EST
Created attachment 659855 [details]
File: smolt_data
Comment 4 Josep Sanz 2012-12-08 10:15:55 EST
Created attachment 659856 [details]
File: core_backtrace
Comment 5 Miroslav Suchý 2013-04-05 04:01:23 EDT

*** This bug has been marked as a duplicate of bug 821799 ***

Note You need to log in before you can comment on or make changes to this bug.