Bug 885317 - (kdevelop-python) Review Request: kdevelop-python - Python Plugin for KDevelop
Review Request: kdevelop-python - Python Plugin for KDevelop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-reviews
  Show dependency treegraph
 
Reported: 2012-12-08 10:32 EST by Minh Ngo
Modified: 2015-02-09 08:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-09 08:27:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
rdieter: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)
Update to version 1.5.2 for fedora 20 (1.88 KB, text/x-rpm-spec)
2014-05-09 10:47 EDT, Giuseppe Marco Randazzo
no flags Details

  None (edit)
Comment 1 Michael Schwendt 2012-12-14 08:46:57 EST
https://fedoraproject.org/wiki/Package_Review_Process
| 
| Wait for someone to review your package! At this point in the process,
| the fedora-review flag is blank, meaning that no reviewer is assigned.

An incorrectly/mistakably set fedora-review flag causes the ticket to be listed as being worked on by somebody.
Comment 2 Rex Dieter 2013-02-09 13:07:51 EST
I can review.

Would appreciate a review swap, consider anything on the kde-reviews tracker,  
https://bugzilla.redhat.com/show_bug.cgi?id=kde-reviews
in particular consider,
https://bugzilla.redhat.com/show_bug.cgi?id=qaccessibilityclient
Comment 3 Rex Dieter 2013-02-09 13:24:22 EST
Some initial comments:

1.  why hardcode python2.7 everywhere?  like,

%global __python %{__python}2.7
BuildRequires: python(abi) = 2.7

Either justify this, or remove it, and use simpler:
BuildRequires: python2-devel
or just
BuildRequires: python-devel

2.  MUST drop this,
desktop-file-install \
  --dir=${RPM_BUILD_ROOT}%{_kde4_datadir}/kde4/services/ \
  --remove-key=Encoding \
  --remove-key=Type \
  --set-key=Type \
  --set-value=Application \
  ${RPM_BUILD_ROOT}/%{_kde4_datadir}/kde4/services/kdevpythonsupport.desktop

.desktop file validation is only for stuff intended for gui menus (ie, stuff under /usr/share/appliations)

3.  SHOULD omit:
BuildRequires:  cmake >= 2.6
(it's superfluous, pulled in already by kdelibs-devel down the stack a ways)

scriptlets: NOT ok.  

4. MUST drop:
%post
update-desktop-database &> /dev/null || :
update-mime-database %{_datadir}/mime &> /dev/null || :

%postun
update-desktop-database &> /dev/null || :
update-mime-database %{_datadir}/mime &> /dev/null || :

this package neither provides app .desktop files with mimetype associations, nor defines it's own mimetype's, so these scriptlets aren't needed.

5.  pkg includes shared library, MUST add scriptlet:
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

6. SHOULD replace %files references :
%{_kde4_datadir}/kde4/apps/
with
%{_kde4_appsdir}/

7.  MUST document what
Patch0:     kdevelop-python-documentation-files.patch
is for.  why is it needed?  what does it fix?  has it been upstreamed?  if not, why not?


naming: ok

licensing: NOT ok, mixture of (at least): BSD, LGPLv2+, GPLv2+, GPLv3+ , 
8.  MUST update License: tag, corresponding to aggregate license (GPLv3+),
License: GPLv3+

sources: ok
8980b2cdb955f8f34f7560ffc940ef1b  kdev-python-v1.4.1.tar.bz2


So far so good, have a handful of issues to address.
Comment 4 Minh Ngo 2013-02-14 03:22:52 EST
Hi again.

1. +
2. +
3. +
4. +
5. +
6. +

7. This patch must needed because Fedora Package builder tries to compile all of python files
into byte codes. There are some syntax errors in these files, so the package building process
will be failed without this patch.

So I think it's not necessary to push it into upstream. 

SRPM: https://dl.dropbox.com/s/m0apcdoc34r5dya/kdevelop-python-1.4.1-2.el6.src.rpm?token_hash=AAFg34QbR4GsnxRK6ImF1VvUsqpqROuvTsZpdE1AoKzxOg&dl=1

SPEC: https://raw.github.com/Ignotus/fedora-packages/0f524c9612c4400ad4a6bc033403340052a0f443/kdevelop-python/kdevelop-python.spec
Comment 5 Minh Ngo 2013-02-14 03:23:49 EST
s/must needed/must be needed/
Comment 6 Rex Dieter 2013-02-14 09:33:46 EST
7.  I still see no comment in .spec documenting what the patch is for. :

8.  I suppose we SHOULD have a dep
Requires: kdevelop
(or does that get already pulled in implicitly via other dependencies?)


otherwise, I see no remaining blockers, APPROVED.
Comment 7 Minh Ngo 2013-02-14 14:31:41 EST
I have commented in the .patch file
Comment 8 Minh Ngo 2013-02-14 14:50:59 EST
New Package SCM Request
=======================
Package Name: kdevelop-python
Short Description: Python Plugin for KDevelop
Owners: minh
Branches: f17 f18
InitialCC:
Comment 9 Jon Ciesla 2013-02-14 15:07:56 EST
Git done (by process-git-requests).
Comment 10 Minh Ngo 2013-02-14 15:13:01 EST
Rex, Jon, thank you.
Comment 11 Rex Dieter 2013-02-15 10:27:55 EST
It was highlighted on irc last night that kdevelop-python bundles a patched copy of python.  Obviously, a non-starter.

Please resolve that prior to issuing any official builds.
Comment 12 Kevin Kofler 2013-03-14 14:03:59 EDT
FYI, I untagged all the builds that have been done (from f19, f18-updates-candidate and f17-updates-candidate).

I'm not sure what to do about this package, it sounds like it might have to get retired again. :-(
Comment 13 john5342 2013-03-24 16:46:26 EDT
FWIW The python 3 version will soon (starting with python 3.4) stop embedding python. More info as to why it is embedded and what is being done about it: http://scummos.blogspot.co.uk/2013/03/various-news-in-kdevelop-kdev-python.html
Comment 14 Kevin Kofler 2013-03-24 18:19:44 EDT
So my proposal: Given that a solution is in sight, try asking FPC for a time-limited exception allowing the bundled libpython. (You will also need to fix the patches to make it build, what you tried applying in your latest build does not work. But that's not worth doing before we know how to proceed.) If FPC accepts, proceed. If they say "no", then the package needs to wait until next year, unfortunately.
Comment 15 Giuseppe Marco Randazzo 2014-05-09 10:47:00 EDT
Created attachment 894058 [details]
Update to version 1.5.2 for fedora 20

I was updating the package to the 1.5.2 which is the o
Hello, 

i think that this package is very usefull. I like to write code with kdevelop and i do not like to installa an other IDE to write code in python. So... I have updated the package to 1.5.2 which is the only one compatible with Fedora 20. 

The package 1.6.1 is not possible to install because the Fedora 20 PythonLib version is not supported.

The question is... 
This package will be available on the official fedora repository or not?

Thanks GMR
Comment 16 Rex Dieter 2014-05-09 11:00:39 EDT
Re: comment #15

> This package will be available on the official fedora repository or not?

Including this package in fedora is blocking on the issue of the bundled copy of python.  That either needs to be removed to use system python, or a request be made to allow an exception (see proposal in comment #14)

As far as I'm aware, neither has happened yet.
Comment 17 Giuseppe Marco Randazzo 2014-05-09 11:11:16 EDT
Ok thanks Rex. So... in the package i was found in the README this... 

Python fork
-----------
kdev-python currently contains a fork of Python 2.7.2 with some custom
adjustments. The fork is contained in the python-src/ subdirectory.
Only the parser of that fork is being built, and the language plugin
links against the resulting library. You can currently NOT replace
that library by the vanilla libpython.so library.
I'm aware that this situation is very undesirable, and measures have
been taken to get rid of the fork: With the release of Python 3.4,
the fork can be removed.


So we have to wait the update of python library in fedora to the version 3.4 to have a package linked with the system python.


Marco
Comment 18 Paul Fee 2014-05-09 11:51:13 EDT
Python 3.4 is in rawhide, so kdev-python could be targetted for Fedora 21.

http://koji.fedoraproject.org/koji/packageinfo?packageID=9781
Comment 19 Kevin Kofler 2015-02-09 08:27:59 EST
We have this imported in Rawhide now, using the system Python 3.
Comment 20 Kevin Kofler 2015-02-09 08:28:39 EST
(Also available in Fedora 21. It entered Rawhide before F21 branched.)

Note You need to log in before you can comment on or make changes to this bug.