Bug 88555 - BAD: ****DHCLIENT***** RH8.0,9.0 Default Versions, DOES NOT RELEASE IPs UPON SHUTDOWN!
BAD: ****DHCLIENT***** RH8.0,9.0 Default Versions, DOES NOT RELEASE IPs UPON...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
:
: 88556 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-10 16:54 EDT by Jusitn Davis
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-11 15:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jusitn Davis 2003-04-10 16:54:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The DHCP package is not used in RH8.0,9.0, and the DHCLIENT package which is
being used in its place does not send releases when the system is shutdown.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot Up
2.Reboot
3.
    

Actual Results:  Messes up DNS Servers which use DHCP info to register
information to the IP.  IP was never released.

Expected Results:  The IP should ALWAYS be released on a shutdown....DUH!!!!

Additional info:
Comment 1 Daniel Walsh 2003-04-11 10:48:33 EDT
*** Bug 88556 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2003-04-11 15:32:54 EDT
From the Man page:

 The  client  normally  doesnât  release  the current lease as it is not
 required by the DHCP protocol.  Some cable ISPs require  their  clients
 to  notify  the  server if they wish to release an assigned IP address.
 The -r flag explicitly releases the current lease, and once  the  lease
 has been released, the client exits.

so running 
/sbin/dhclient -r -lf /var/lib/dhcp/dhclient-eth0.leases -pf
/var/run/dhclient-eth0.pid

should release the eth0 device. 

Note You need to log in before you can comment on or make changes to this bug.