Bug 885641 - partitioning: Continue says I don't have enough space, Done says I do
partitioning: Continue says I don't have enough space, Done says I do
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-10 05:02 EST by Kamil Páral
Modified: 2012-12-17 04:30 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-17 04:30:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration video (595.14 KB, video/ogg)
2012-12-10 05:02 EST, Kamil Páral
no flags Details
anaconda.log (9.40 KB, text/plain)
2012-12-10 05:03 EST, Kamil Páral
no flags Details
packaging.log (413.71 KB, text/plain)
2012-12-10 05:03 EST, Kamil Páral
no flags Details
program.log (33.64 KB, text/plain)
2012-12-10 05:03 EST, Kamil Páral
no flags Details
storage.log (88.61 KB, text/plain)
2012-12-10 05:03 EST, Kamil Páral
no flags Details
syslog (56.66 KB, text/plain)
2012-12-10 05:03 EST, Kamil Páral
no flags Details
18.37.2 main hub (53.85 KB, image/png)
2012-12-14 08:17 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-12-10 05:02:33 EST
Created attachment 660658 [details]
bug demonstration video

Description of problem:
In the partitioning screen if I hit Continue, I'm warned that I don't have enough space to install Fedora. But when I hit Done, I'm not warned at all and no warning appears even in the main hub screen. When I start the installation, right after my partitions are modified anaconda tells me I don't have enough free space.

Watch the attached video.

Version-Release number of selected component (if applicable):
anaconda 18.37

How reproducible:
always

Steps to Reproduce:
1. create a single partition on disk leaving about 5 GB free space
2. enter partitioning screen
3. hit Continue, you are warned. Hit Cancel. Hit Done, you are not warned.
4. Start installation.

Actual results:
disk layout is modified but installation is not complete

Expected results:
either you are warned in advance, or installation finishes successfully
Comment 1 Kamil Páral 2012-12-10 05:03:31 EST
Created attachment 660661 [details]
anaconda.log
Comment 2 Kamil Páral 2012-12-10 05:03:35 EST
Created attachment 660662 [details]
packaging.log
Comment 3 Kamil Páral 2012-12-10 05:03:38 EST
Created attachment 660663 [details]
program.log
Comment 4 Kamil Páral 2012-12-10 05:03:42 EST
Created attachment 660664 [details]
storage.log
Comment 5 Kamil Páral 2012-12-10 05:03:46 EST
Created attachment 660665 [details]
syslog
Comment 6 Kamil Páral 2012-12-10 05:04:57 EST
This is a very nasty bug, proposing as a blocker. Any generic anaconda release criterion should do.
Comment 7 Kamil Páral 2012-12-10 12:55:06 EST
In the video I clicked Continue to illustrate that in that case anaconda checks the size of the installation. But I can reproduce it without problems by just hitting Done right away.
Comment 8 gpryzby@gmail.com 2012-12-11 10:41:46 EST
If you try to reuse partitions (move them from Fedora 17 to 18) you get the same error. I wanted to 'upgrade/reinstall' and reuse /boot, / and swap, leaving /home alone. 

NO SPACE error.
Comment 9 Vratislav Podzimek 2012-12-14 07:46:05 EST
Kamil, can you still reproduce this with some recent image? I've tried Rawhide anaconda and was not able to reproduce it. From git diff I see that the patch for bug #853636 that is only on master and not on f18-branch brought some changes.
Comment 10 Vratislav Podzimek 2012-12-14 07:51:03 EST
If you can reproduce this with a recent image, could you please try using http://vpodzime.fedorapeople.org/space_check_updates.img ? It contains the patch for bug #853636 ported to f18-branch and applies to anaconda-18.37.2-1
Comment 11 Kamil Páral 2012-12-14 08:17:58 EST
Created attachment 663578 [details]
18.37.2 main hub

Actually this is fixed with 18.37.2, no updates.img needed. It displays an error in the main hub. The partitioning icon does not include a warning triangle, and I think it should, but this particular issue is solved.
Comment 12 Kamil Páral 2012-12-14 08:19:38 EST
(In reply to comment #11)
Also it's worth mentioning that Begin installation can't be clicked. Very good.
Comment 13 Kamil Páral 2012-12-17 04:30:52 EST
Anaconda was pushed stable, closing.

Note You need to log in before you can comment on or make changes to this bug.