Bug 885882 - Xorg issues w/ Intel i915 driver on RHEL 6.4 beta
Summary: Xorg issues w/ Intel i915 driver on RHEL 6.4 beta
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mesa
Version: 6.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Dave Airlie
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 887759 895654
TreeView+ depends on / blocked
 
Reported: 2012-12-10 21:37 UTC by Ben Breard
Modified: 2013-03-21 08:22 UTC (History)
2 users (show)

Fixed In Version: mesa-9.0-0.3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 887759 (view as bug list)
Environment:
Last Closed: 2013-02-21 08:49:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
dmesg log (86.45 KB, application/octet-stream)
2012-12-10 21:37 UTC, Ben Breard
no flags Details
xorg log (63.95 KB, text/plain)
2012-12-10 21:38 UTC, Ben Breard
no flags Details
glxinfo (14.27 KB, text/plain)
2012-12-11 17:06 UTC, Ben Breard
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0344 normal SHIPPED_LIVE mesa bug fix and enhancement update 2013-02-20 20:53:50 UTC

Description Ben Breard 2012-12-10 21:37:02 UTC
Created attachment 661156 [details]
dmesg log

Description of problem:
After upgrading to 6.4 beta I noticed that desktop compositing isn't working. There are several warnings and errors in Xorg.0.log. I'm using a fairly standard Lenovo X220 laptop.

Version-Release number of selected component (if applicable):
RHEL 6.4 Beta. 

How reproducible:
100%

Steps to Reproduce:
1. install 
2. boot
  

Additional info:

I'm happy to try out any test packages and/or provide additional info. Thanks.

Comment 1 Ben Breard 2012-12-10 21:38:09 UTC
Created attachment 661157 [details]
xorg log

Comment 3 Adam Jackson 2012-12-11 15:13:42 UTC
Odd, the X log certainly thinks GL is working.  Can you attach the output from glxinfo?

Comment 4 Ben Breard 2012-12-11 17:06:52 UTC
Created attachment 661573 [details]
glxinfo

Here you go.

Comment 5 Ben Breard 2012-12-14 05:48:56 UTC
I should add that Gnome seems to work fine with compositing. This only effects the version of KDE that ships w/ RHEL 6. All previous minor releases of RHEL 6 worked perfectly. Than seems to think this is more likely an issue w/ mesa that Xorg. Any idea how to track this down?

Comment 6 Ben Breard 2012-12-15 01:46:42 UTC
I can confirm that downgrading mesa* to 7.11-5 fixes this issue. Apparently the rebase of mesa is what's causing problems with KDE. I've reassigned this BZ to mesa. Please let me know if there's any other debug info I can provide. 

This is 100% reproducible.

Comment 8 Dave Airlie 2012-12-17 02:44:35 UTC
okay I've ruled out MSAA as the culprit, now sure where to go next, kwin isn't the most verbose with its info.

Comment 9 Dave Airlie 2012-12-17 04:13:11 UTC
okay more info, this is due to kwin forcing an indirect context and that breaking.

running KWIN_DIRECT_GL=1 makes it work, so we need to track down what broke indirect context for kwin.

Comment 10 Dave Airlie 2012-12-17 05:54:08 UTC
okay two issues

a) indirect rendering was broken, patch posted upstream, and here

b) msaa confuses kwin.

will work out the fix for (b)

Comment 11 Dave Airlie 2012-12-17 06:08:31 UTC
This will require an X server bug as well.

Comment 12 RHEL Program Management 2012-12-17 06:20:47 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 17 Dave Airlie 2012-12-19 02:04:39 UTC
mesa-9.0-0.3.el6 

is built in brew

Comment 26 errata-xmlrpc 2013-02-21 08:49:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0344.html


Note You need to log in before you can comment on or make changes to this bug.