Bug 887759 - Indirect rendering broken was Xorg issues w/ Intel i915 driver on RHEL 6.4 beta,
Indirect rendering broken was Xorg issues w/ Intel i915 driver on RHEL 6.4 beta,
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: Regression
Depends On: 885882
Blocks: 895654
  Show dependency treegraph
 
Reported: 2012-12-17 04:18 EST by Dave Airlie
Modified: 2013-03-21 04:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.13.0-10.el6
Doc Type: Bug Fix
Doc Text:
No documentation required. internal bug found during development.
Story Points: ---
Clone Of: 885882
Environment:
Last Closed: 2013-02-21 03:04:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Dave Airlie 2012-12-17 04:22:50 EST
To test for indirect rendering brokenness

LIBGL_ALWAYS_INDIRECT=y glxinfo

run this 5-10 times, it should fail with BadAlloc every so often, here it fails on the 2nd go pretty reliable.

The fix is
http://lists.x.org/archives/xorg-devel/2012-December/034801.html
Comment 3 RHEL Product and Program Management 2012-12-17 04:33:36 EST
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 4 Tomas Pelka 2012-12-17 05:59:58 EST
(In reply to comment #1)
> To test for indirect rendering brokenness
> 
> LIBGL_ALWAYS_INDIRECT=y glxinfo
> 
> run this 5-10 times, it should fail with BadAlloc every so often, here it
> fails on the 2nd go pretty reliable.
> 
> The fix is
> http://lists.x.org/archives/xorg-devel/2012-December/034801.html

Got it, acking.
Comment 5 Dave Airlie 2012-12-18 20:26:09 EST
xorg-x11-server-1.13.0-10 is built in brew.
Comment 9 errata-xmlrpc 2013-02-21 03:04:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html

Note You need to log in before you can comment on or make changes to this bug.