Bug 885932 - quantum-node-setup fails to set libvirt_vif_driver with "--plugin openvswitch"
quantum-node-setup fails to set libvirt_vif_driver with "--plugin openvswitch"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-quantum (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gary Kotton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 22:27 EST by Etsuji Nakai
Modified: 2016-04-26 12:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 903304 (view as bug list)
Environment:
Last Closed: 2013-03-21 20:00:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested patch for /usr/bin/quantum-node-setup (411 bytes, patch)
2012-12-10 22:27 EST, Etsuji Nakai
no flags Details | Diff

  None (edit)
Description Etsuji Nakai 2012-12-10 22:27:37 EST
Created attachment 661271 [details]
Suggested patch for /usr/bin/quantum-node-setup

Description of problem:

"quantum-node-setup --plugin openvswitch" reports error as below:

-----------
# quantum-node-setup --plugin openvswitch
Quantum plugin: openvswitch
Please enter the Quantum hostname:
opst01
Would you like to update the nova configuration files? (y/n): 
y
/usr/bin/openstack-config --set|--del config_file section [parameter] [value]
Configuration updates complete!
-----------

This is because LIBVIRT_VIF_DRIVER is not set for openvswitch.

/usr/bin/quantum-node-setup
-----------
    116 case "${QUANTUM_PLUGIN}" in
    117 "linuxbridge")
    118         LIBVIRT_VIF_DRIVER=nova.virt.libvirt.vif.QuantumLinuxBridgeVIFDrive        r
    119 ;;
    120 
    121 "openvswitch")
    122         if ! rpm -q openvswitch > /dev/null
    123         then
    124                 echo "Please install openvswitch"
    125                 exit 0
    126         fi
    127 ;;
    128 
    129 esac
-----------

See the attachment for a suggested patch.

By the way, I used "LibvirtHybridOVSBridgeDriver" in this patch. There may be another choice of driver, though.

Version-Release number of selected component (if applicable):

# rpm -q openstack-quantum
openstack-quantum-2012.2.1-1.fc18.noarch
Comment 1 Gary Kotton 2013-01-21 05:20:35 EST
Currently updated with f18 packages
Comment 2 Fedora Update System 2013-01-21 05:24:33 EST
openstack-quantum-2012.2.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-quantum-2012.2.1-2.fc18
Comment 3 Fedora Update System 2013-01-22 20:41:21 EST
Package openstack-quantum-2012.2.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-quantum-2012.2.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1232/openstack-quantum-2012.2.1-2.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-03-11 21:20:36 EDT
openstack-quantum-2012.2.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-quantum-2012.2.3-2.fc18
Comment 5 Fedora Update System 2013-03-21 20:00:29 EDT
openstack-quantum-2012.2.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.