Bug 886190 - 3.2 - bootstrap fails if PREFIX is used for network configuration
3.2 - bootstrap fails if PREFIX is used for network configuration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.2.0
Assigned To: Dan Kenigsberg
Meni Yakove
network
:
: 886882 (view as bug list)
Depends On:
Blocks: 889423 915537
  Show dependency treegraph
 
Reported: 2012-12-11 13:11 EST by Petr Spacek
Modified: 2016-02-10 14:57 EST (History)
11 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 889423 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Spacek 2012-12-11 13:11:57 EST
Description of problem:
Attempt to add the host to RHEV-M 3.1 with RHEL 6.3 vdsm fails if network interface is configured with PREFIX option instead of NETMASK option.

Version-Release number of selected component (if applicable):
vdsm-4.9.6-44.0.el6_3.x86_64
RHEV-M 3.1

How reproducible:
100 %


Steps to Reproduce:
1. configure network interface with PREFIX instead of NETMASK in /etc/sysconfig/network-scripts/ifcfg-eth0
2. try to add host to RHEV 3.1


Actual results:
RHEV-M 3.1 shows:
Failed to install 3.1 Host: Step: SetNetworking; Details: addNetwork error trying to add management bridge.

Expected results:
Host installs fine.


Additional info:
According to /usr/share/doc/initscripts-9.03.31/sysconfig.txt PREFIX without NETMASK is legal.

    PREFIXn=
      Network prefix.  It is used for all configurations except aliases
      and ippp devices.  It takes precedence over NETMASK when both
      PREFIX and NETMASK are set.
    NETMASKn=
      Subnet mask; just useful for aliases and ippp devices.  For all other
      configurations, use PREFIX instead.

    The "n" is expected to be consecutive positive integers starting from 0.
    It can be omitted if there is only one address being configured.

Also, PREFIX is "the right way" according to RHCE (RH300) for RHEL 6.3.


Workaround:
Replace PREFIX with NETMASK in ifcfg-* files.
Comment 3 Petr Spacek 2012-12-11 13:17:55 EST
Log /tmp/vdsm-bootstrap-phase1-20121211182139.log showed following error:

Tue, 11 Dec 2012 18:20:03 DEBUG    deployUtil 940 makeBridge found the following bridge paramaters: ['ONBOOT=yes', 'BOOTPROTO=static', 'IPADDR=1.2.3.4', 'PREFIX=24', 'G
ATEWAY=1.2.3.111', 'IPV6_AUTOCONF=no', 'ONBOOT=yes']
Tue, 11 Dec 2012 18:20:03 DEBUG    deployUtil 136 ['/usr/share/vdsm/addNetwork', 'rhevm', '', '', 'eth0', 'ONBOOT=yes', 'BOOTPROTO=static', 'IPADDR=1.2.3.4', 'PREFIX=24
', 'GATEWAY=1.2.3.111', 'IPV6_AUTOCONF=no', 'ONBOOT=yes', 'blockingdhcp=true']
Tue, 11 Dec 2012 18:20:03 DEBUG    deployUtil 144 Must specify netmask to configure ip for network

Tue, 11 Dec 2012 18:20:03 DEBUG    deployUtil 145 WARNING:root:options IPADDR is deprecated. Use ipaddr instead
WARNING:root:options GATEWAY is deprecated. Use gateway instead
WARNING:root:options BOOTPROTO is deprecated. Use bootproto instead
WARNING:root:options ONBOOT is deprecated. Use onboot instead
Traceback (most recent call last):
  File "/usr/share/vdsm/configNetwork.py", line 1450, in <module>
    main()
  File "/usr/share/vdsm/configNetwork.py", line 1419, in main
    addNetwork(bridge, **kwargs)
  File "/usr/share/vdsm/configNetwork.py", line 886, in addNetwork
    bridged=bridged, **options)
  File "/usr/share/vdsm/configNetwork.py", line 816, in _addNetworkValidation
    "Must specify netmask to configure ip for network")
ConfigNetworkError: (22, 'Must specify netmask to configure ip for network')

Tue, 11 Dec 2012 18:20:03 DEBUG    deployUtil 980 makeBridge Failed to add rhevm bridge out=Must specify netmask to configure ip for network

err=WARNING:root:options IPADDR is deprecated. Use ipaddr instead
WARNING:root:options GATEWAY is deprecated. Use gateway instead
WARNING:root:options BOOTPROTO is deprecated. Use bootproto instead
WARNING:root:options ONBOOT is deprecated. Use onboot instead
Traceback (most recent call last):
  File "/usr/share/vdsm/configNetwork.py", line 1450, in <module>
    main()
  File "/usr/share/vdsm/configNetwork.py", line 1419, in main
    addNetwork(bridge, **kwargs)
  File "/usr/share/vdsm/configNetwork.py", line 886, in addNetwork
    bridged=bridged, **options)
  File "/usr/share/vdsm/configNetwork.py", line 816, in _addNetworkValidation
    "Must specify netmask to configure ip for network")
ConfigNetworkError: (22, 'Must specify netmask to configure ip for network')

ret=22
Tue, 11 Dec 2012 18:20:03 ERROR    deployUtil 995 makeBridge errored:  out=Must specify netmask to configure ip for network
err=WARNING:root:options IPADDR is deprecated. Use ipaddr instead
WARNING:root:options GATEWAY is deprecated. Use gateway instead
WARNING:root:options BOOTPROTO is deprecated. Use bootproto instead
WARNING:root:options ONBOOT is deprecated. Use onboot instead
Traceback (most recent call last):
  File "/usr/share/vdsm/configNetwork.py", line 1450, in <module>
    main()
  File "/usr/share/vdsm/configNetwork.py", line 1419, in main
    addNetwork(bridge, **kwargs)
  File "/usr/share/vdsm/configNetwork.py", line 886, in addNetwork
    bridged=bridged, **options)
  File "/usr/share/vdsm/configNetwork.py", line 816, in _addNetworkValidation
    "Must specify netmask to configure ip for network")
ConfigNetworkError: (22, 'Must specify netmask to configure ip for network')

ret=22
Tue, 11 Dec 2012 18:20:03 DEBUG    deployUtil 998 makeBridge return.
Tue, 11 Dec 2012 18:20:03 ERROR    vds_bootstrap 656 addNetwork error trying to add management bridge
Tue, 11 Dec 2012 18:20:03 DEBUG    vds_bootstrap 213 <BSTRAP component='SetNetworking' status='FAIL' message='addNetwork error trying to add management bridge'/>
Tue, 11 Dec 2012 18:20:03 ERROR    vds_bootstrap 922 setNetworking test failed
Tue, 11 Dec 2012 18:20:03 DEBUG    vds_bootstrap 1019 <BSTRAP component='RHEV_INSTALL' status='FAIL'/>
Tue, 11 Dec 2012 18:20:03 DEBUG    vds_bootstrap 1021 **** End VDS Validation ****
Comment 5 Alon Bar-Lev 2012-12-11 17:25:52 EST
dup of bug#866540?
Comment 6 Dan Kenigsberg 2012-12-11 18:31:07 EST
(In reply to comment #5)
> dup of bug#866540?

Yes, but on a different product. Suggesting to fix in rhev=3.2.

As a workaround, please replace PREFIX=24 with NETMASK=255.255.255.0 (24 leading 1 bits).

https://gerrit.eng.lab.tlv.redhat.com/3720
https://gerrit.eng.lab.tlv.redhat.com/3721
Comment 7 Dan Kenigsberg 2012-12-20 04:50:19 EST
*** Bug 886882 has been marked as a duplicate of this bug. ***
Comment 8 Meni Yakove 2013-01-08 07:40:30 EST
Verified on vdsm-4.10.2-3.0.el6ev.x86_64.

ifcfg-eth0 was with PREFIX=24
ifcfg-rhevm was created with NETMASK=255.255.255.0
Comment 10 Itamar Heim 2013-06-11 04:58:26 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:58:26 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:58:27 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 05:00:17 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:29:54 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.