Bug 886357 - [Release Notes] Deprecate version 1 of the QMF API
[Release Notes] Deprecate version 1 of the QMF API
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Release_Notes (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity unspecified
: 2.3
: ---
Assigned To: Joshua Wulf
Petr Matousek
:
Depends On: 885205
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-12 01:21 EST by Cheryn Tan
Modified: 2014-10-19 19:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 885205
Environment:
Last Closed: 2013-03-19 12:38:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cheryn Tan 2012-12-12 01:21:14 EST
+++ This bug was initially created as a clone of Bug #885205 +++

QMF 1 is now superceded by the QMF 2 API.  QMF 1 is not ABI-stable, and no one should use it.

--- Additional comment from Justin Ross on 2012-12-08 05:19:01 CST ---

Ted, what are the namespaces of the QMF 1 APIs?

--- Additional comment from Ted Ross on 2012-12-08 05:23:15 CST ---

(In reply to comment #1)
> Ted, what are the namespaces of the QMF 1 APIs?

qpid::management
qpid::console

Note that internal to the qpid broker, there are some definitions in qpid::management that are not to be deprecated as they support both v1 and v2 protocols.
Comment 3 Petr Matousek 2013-02-25 03:55:10 EST
Deprecation info provided. Content approved.

Documentation used for verification:
Release Notes for the Red Hat Enterprise MRG 2 
Revision 1-12

Note You need to log in before you can comment on or make changes to this bug.