Bug 886743 - Test case failure: L10N: Content Management - Activation Keys
Test case failure: L10N: Content Management - Activation Keys
Status: CLOSED DUPLICATE of bug 878338
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-12 21:52 EST by Angela Garcia
Modified: 2012-12-13 05:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: 1. when trying to save a new activation key it shows an unlocalized error message. Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 05:14:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Angela Garcia 2012-12-12 21:52:51 EST
1. when trying to save a new activation key it shows an unlocalized error message.

Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

Depending on user's permissions, hover the mouse over the available tabs and
submenu as well as upper right links (i.e. Notifications count, Logout link,
etc)

1. Create a New Activation Key

  * Move cursor over Content ? Subscriptions and click Activation Keys.
  * Click the + New Key button.
  * Type in a name for the new activation key in the Name field.
  * Type in a description in the Description field.
  * Select the Environment.
  * Type the number for the Usage Limit OR checked the Unlimited.
  * Click the Save button to create your new activation key.
  * Check the Details subtab and click the Save button to save your changes.


2. Add Subscriptions to Activation Key

  * Select the activation key you wish to add subscriptions to.
  * Click on the Available Subscriptions application subtab. A list of
    available subscriptions is displayed.
  * Select the subscriptions you wish to add.
  * Click the Add to Key button to add subscriptions to the activation key.
  * Perform a Filter (Click/Type on the left Filter... field).


3. Remove Subscriptions from Activation Key

  * Select the activation key you wish to remove subscriptions from.
  * Click the Applied Subscriptions application subtab.
  * A list of subscriptions is displayed. Select the subscriptions you wish to
    remove.
  * Click the Remove button to remove subscriptions from the activation key.
  * Perform a Filter (Click/Type on the left Filter... field).
  * Click Add Subscriptions link button links back to Available Subscriptions
    subtab.


4. Check the Systems subtab.

  * Select an exisiting activation key from the list of the left.
  * Click on the Systems subtab. Check the stystems information.


5. Perform a search (Click/Type on Search..., click on the arrow drop-dwon
button next to search: Save as Favorite, Clear the Search)

6. Remove Activation Key

  * Select the exisiting activation key you wish to remove from the list of the
    left.
  * Click the Remove Activation Key button.
  * Choose Yes on the 'Are you sure...?' confirmation alert box.

 



Actual results: 
#FIXME

Expected results:
Check every screen/step for the following:

  * Translations complete? All strings should be localized. Make sure to also
    check the translations of warning/info messages that come up on top of the
    screen, as well as tool-tips where applicable.
  * Translations correct? Translations should be correct, e.g. spelling,
    grammar, terminology, plural forms etc. especially when variables where
    were used in strings
  * Appearance of translations, e.g. rendering, fits okay in available space
    (buttons/lists etc.)
Comment 1 Lijun Li 2012-12-13 05:14:11 EST

*** This bug has been marked as a duplicate of bug 878338 ***

Note You need to log in before you can comment on or make changes to this bug.