Bug 887069 - [ALL_LANG][SAM CLI] Unlocalized strings for domain module
[ALL_LANG][SAM CLI] Unlocalized strings for domain module
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Katello Bug Bin
SAM QE List
: i18n, Translation, Triaged
: 887093 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 20:29 EST by Noriko Mizumoto
Modified: 2014-09-18 12:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 14:45:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2012-12-13 20:29:19 EST
Description of problem:
Unlocalized strings for domain module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.-6h.el6_3

How reproducible:
100%

Steps to Reproduce:

[root@i18nsamtest ~]# headpin domain -h
Usage:  headpin <options> domain <command>
Supported Commands:
	create         create domain
	delete         delete domain
	info           show information about a domain
	list           list domains
	update         update domain

Options:
  -h, --help  show this help message and exit


[root@i18nsamtest ~]# headpin domain create -h
Usage:  headpin <options> domain create <options>

Options:
  -h, --help           show this help message and exit
  --name=NAME          The full DNS Domain name
  --fullname=FULLNAME  Full name describing the domain
  --dns_id=DNS_ID      DNS Proxy to use within this domain
  -g                   grep が使いやすい出力
  -v                   詳細な構造化された出力
  -d DELIMITER         grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading          ヘッディングの出力を表示しません。出力を grep する場合に便利です。



Actual results:
Unlocalized strings for activation_key module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Eunju, Kim 2012-12-13 23:57:43 EST
confirmed for ko-KR.

Also there is another one unlocalized.
[root@i18nsamtest ~]# headpin domain info -h
Usage:  headpin <options> domain info <options>

Options:
  -h, --help    show this help message and exit
  --name=ID     domain id or name
  -g            grep 출력 결과
  -v            상세하고 보다 구조화된 출력 결과
  -d DELIMITER  grep 출력 결과에서 컬럼 구분 기호, -g 옵션을 선택한 경우에만 작동함
  --noheading   제목 출력을 표시하지 않습니다. 출력을 grep할 때 유용합니다.
Comment 2 Hedda Peters 2012-12-14 00:10:50 EST
Confirmed for de-DE, plus:

[root@i18nsamtest ~]# headpin domain list -h
Usage:  headpin <options> domain list <options>

Options:
  -h, --help       show this help message and exit
  --search=SEARCH  Filter results
  --order=ORDER    Sort results
Comment 3 Sam Friedmann 2012-12-14 00:42:32 EST
Confirmed for fr-FR.
Comment 4 Tom McKay 2012-12-18 09:12:13 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 6 Lijun Li 2012-12-18 22:19:10 EST
Build: SAM-1.2-RHEL-6-20121211.n.0

katello-headpin-all.noarch 0:1.2.6-6h.el6_3 

[root@i18nsamtest ~]# headpin domain -h
Usage:  headpin <options> domain <command>
Supported Commands:
	create         create domain
	delete         delete domain
	info           show information about a domain
	list           list domains
	update         update domain

Options:
  -h, --help  show this help message and exit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
[root@i18nsamtest ~]# headpin domain create -h
Usage:  headpin <options> domain create <options>

Options:
  -h, --help           show this help message and exit
  --name=NAME          The full DNS Domain name
  --fullname=FULLNAME  Full name describing the domain
  --dns_id=DNS_ID      DNS Proxy to use within this domain
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g                   grep が使いやすい出力
  -v                   詳細な構造化された出力
  -d DELIMITER         grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading          ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]#  headpin domain delete -h
Usage:  headpin <options> domain delete <options>

Options:
  -h, --help    show this help message and exit
  --name=ID     domain id or name
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin domain info -h
Usage:  headpin <options> domain info <options>

Options:
  -h, --help    show this help message and exit
  --name=ID     domain id or name
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin domain list -h
Usage:  headpin <options> domain list <options>

Options:
  -h, --help       show this help message and exit
  --search=SEARCH  Filter results
  --order=ORDER    Sort results
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g               grep が使いやすい出力
  -v               詳細な構造化された出力
  -d DELIMITER     grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading      ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin domain update -h
Usage:  headpin <options> domain update <options>

Options:
  -h, --help           show this help message and exit
  --name=ID            Domain id
  --new_name=NAME      The full DNS Domain name(required)
  --fullname=FULLNAME  Full name describing the domain
  --dns_id=DNS_ID      DNS Proxy to use within this domain
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g                   grep が使いやすい出力
  -v                   詳細な構造化された出力
  -d DELIMITER         grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading          ヘッディングの出力を表示しません。出力を grep する場合に便利です。
Comment 7 Lijun Li 2012-12-18 22:20:34 EST
*** Bug 887093 has been marked as a duplicate of this bug. ***
Comment 8 Miroslav Suchý 2013-02-12 04:37:18 EST
This will have to wait translation team just before next release of CFSE, which is not yet scheduled.
If you want this change in upstream sooner, you can help translate it here:
https://www.transifex.com/projects/p/katello/
Comment 9 Bryan Kearney 2014-01-08 14:45:29 EST
Closing all L10N bugs until we can do a full translation path through the code.

Note You need to log in before you can comment on or make changes to this bug.