Bug 887211 - reusing same manifest (after org removed) brings traceback on candlepin side
reusing same manifest (after org removed) brings traceback on candlepin side
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: candlepin-bugs
Katello QA List
: Triaged, ZStream
Depends On:
Blocks: 896232
  Show dependency treegraph
 
Reported: 2012-12-14 05:25 EST by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 896232 (view as bug list)
Environment:
Last Closed: 2013-12-03 09:57:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fail (107.94 KB, image/png)
2012-12-14 05:25 EST, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2012-12-14 05:25:48 EST
Created attachment 663478 [details]
fail

Description of problem:
trying to reuse the manifest (org removed, trying to import for other or the same manifest). it fails on candlepin side with traceback (attached):

Version-Release number of selected component (if applicable):
latest release: 1.1

How reproducible:
from 1st attempt

Steps to Reproduce:
(all via UI)
create org, environment
switch to that org
import manifest
enable repo (e.g SAM RPMs)
sync repo
promote to env
switch back to default org
delete the org
create another one
import _same_ manifest


Actual results:
traceback (attached)

Expected results:
possible to reuse the manifest

Additional info:
http://pastebin.test.redhat.com/119877
Comment 7 Tom McKay 2013-02-25 16:33:15 EST
Apologies, moving back to Brad since I see this is a pulp issue and not really candlepin.
Comment 8 Brad Buckingham 2013-08-12 11:32:27 EDT
Garik, can you confirm if this issue remains with Sat6?  If so, provide access to current logs?  Thanks!
Comment 9 Garik Khachikyan 2013-12-03 09:57:07 EST
ah, it already fixed while ago.

we have many tests passing and it is fixed. closing this. thanks.

Note You need to log in before you can comment on or make changes to this bug.