Bug 887715 - Changes to external trackers
Summary: Changes to external trackers
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: Simon Green
QA Contact: tools-bugs
URL:
Whiteboard:
: 1012162 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-17 04:21 UTC by Simon Green
Modified: 2014-10-12 22:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-11 22:39:29 UTC


Attachments (Terms of Use)

Comment 1 Simon Green 2012-12-17 04:22:04 UTC
I've budgeted 40 hours for this. I don't expect every external tracker to be done. If we cover Bugzilla, JIRA, PHP and any other heavily used tracker, that will be good enough.

  -- simon

Comment 2 Simon Green 2012-12-17 05:39:36 UTC
In laymen's terms this is the change we are going to be making:

1) Enforce that the External Bug value looks valid (e.g. is an integer for Bugzilla bugs)

2) Update the summary, status and priority of these external bugs, assuming the bug/issue is publicly visible, and there is an RPC/REST interface available. This is true for Bugzilla and JIRA, which make up a lot of the external trackers.

Comment 3 Alasdair Kergon 2012-12-17 10:27:06 UTC
(In reply to comment #2)

> 1) Enforce that the External Bug value looks valid (e.g. is an integer for
> Bugzilla bugs)

Or an alias?

Comment 4 Simon Green 2013-01-04 08:58:07 UTC
(In reply to comment #3)
> Or an alias?

Not for an external Bugzilla bug. Aliases can changed to point to a different bug (or be removed). This would make the link useless. By enforcing an integer for a Bugzilla bug, you are ensured that the bug link remains valid (doesn't help if they nuke a database, and start counting from one again, but that is a whole different issue)

  -- simon

Comment 5 Alasdair Kergon 2013-01-04 13:00:53 UTC
I was thinking of the way we use aliases for CVEs, for example, which might be *better* than referencing a specific bug number.  I would think this is a matter for the user to decide based on the context, not something for a 'one size fits all' policy.

Comment 6 Simon Green 2013-01-04 18:58:45 UTC
Actually a more important reason that it cannot be an alias is the change we are going to make is actually track the external tracker. For this to happen (for Bugzilla) we need the bug id, as the RPC call won't accept an alias in the Bug.get value.

  -- simon

Comment 12 Simon Green 2013-10-07 23:48:00 UTC
*** Bug 1012162 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.