Bug 887861 - Agent raise OutOfMemoryError when adding new Deployment child resource on AS7
Agent raise OutOfMemoryError when adding new Deployment child resource on AS7
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.1
All All
medium Severity medium
: ER01
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
: 829399 978521 (view as bug list)
Depends On: 887320
Blocks: 952337
  Show dependency treegraph
 
Reported: 2012-12-17 08:48 EST by Thomas Segismont
Modified: 2014-01-02 15:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 887320
: 952337 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Successful deploy of jenkins.war file. (91.17 KB, image/png)
2013-09-26 07:50 EDT, jvlasak
no flags Details

  None (edit)
Description Thomas Segismont 2012-12-17 08:48:39 EST
+++ This bug was initially created as a clone of Bug #887320 +++

Description of problem:
When you try to add new deployment child to an AS7 resource, the agent raise an  OutOfMemoryError.

Version-Release number of selected component (if applicable):
4.6.0-SNAPSHOT

How reproducible:
Always

Steps to Reproduce:
1. Find a simple WAR to deploy
I tried with Jenkins http://mirrors.jenkins-ci.org/war/latest/jenkins.war
2. Go to an AS7 resource page, Inventory/Child Resources tab.
3. Click the toggle button Create Child/Deployment and upload you WAR, then Next and Finish
4. Go to the Inventory/Child History tab
  
Actual results:
The new Created Child history record ends with status failed. A big stack trace ending with OutOfMemoryError is in the history details (see attached stack trace).

Expected results:
The new Created Child history record ends with status success.

Additional info:
* Attached is the server stack trace. The error is catched and passed to the server so it's reported on the server but actually raised in the agent.
* Deploying the same war to a Tomcat 7 resource works. So it may be a problem only for the AS7 plugin

--- Additional comment from Thomas SEGISMONT on 2012-12-14 17:50:28 CET ---

Created attachment 663660 [details]
Stack trace

--- Additional comment from Charles Crouch on 2012-12-14 18:29:08 CET ---

Notes:  http://mirrors.jenkins-ci.org/war/latest/jenkins.war is 46mb

Is this also a problem in jon311?
Comment 1 Thomas Segismont 2012-12-17 09:16:18 EST
Fixed: jon3.1.x - f87210f

Cherry-picked from master - 52bdd6f
Comment 2 Charles Crouch 2012-12-17 10:00:15 EST
Setting back to new. Thomas got a little carried away and committed this too the wrong branch. If this gets triaged into the release it will be cherry-picked to release/jon3.1.x
Comment 3 Thomas Segismont 2013-02-14 08:47:57 EST
Fix tested on JON 3.2 Alpha. Master commit: 84b4cbc
Comment 4 Thomas Segismont 2013-04-08 17:38:58 EDT
Reworked to upgrade to HttpClient 4

master - 21ec5e2
Comment 5 Thomas Segismont 2013-04-09 06:08:00 EDT
Reworked to increased delay in AS7 itests to discover all resources
master - 3b18013
Comment 6 Thomas Segismont 2013-04-10 08:20:18 EDT
Changes reported to release/jon3.1.x - 89d941d

All unit and integration tests pass on my box and on Jenkins:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/RHQ/job/rhq-master/org.rhq$rhq-jboss-as-7-plugin/

Manual testing leads to expected results (see the steps listed in the original description of this bug)
Comment 7 Thomas Segismont 2013-06-13 10:43:38 EDT
*** Bug 829399 has been marked as a duplicate of this bug. ***
Comment 8 Amana 2013-06-27 13:44:01 EDT
*** Bug 978521 has been marked as a duplicate of this bug. ***
Comment 9 Larry O'Leary 2013-09-06 10:30:48 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 10 jvlasak 2013-09-26 07:50:35 EDT
Created attachment 803372 [details]
Successful deploy of jenkins.war file.

Deploying for large war file (jenkins.war) was verified. See screenshot.
Comment 11 Armine Hovsepyan 2013-11-05 04:37:26 EST
marking as verified on behalf of jvlasak

Note You need to log in before you can comment on or make changes to this bug.