Bug 887909 - PRD33 - auto shrink qcow volumes on merge of block volumes
PRD33 - auto shrink qcow volumes on merge of block volumes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Yeela Kaplan
Leonid Natapov
storage
: Improvement
: 974124 (view as bug list)
Depends On: 888008 977089
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-17 10:26 EST by Yeela Kaplan
Modified: 2016-02-10 15:26 EST (History)
16 users (show)

See Also:
Fixed In Version: is8
Doc Type: Enhancement
Doc Text:
Previously the size of a newly merged volume was the sum of the original volumes' virtual sizes. With qcow volumes on block devices the whole size of the new volume is not used, so now VDSM allocates only the actual size needed by the new volume.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:04:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 9725 None None None Never

  None (edit)
Description Yeela Kaplan 2012-12-17 10:26:33 EST
Description of problem:

On merge of qcow volumes on block the new volume after merge has the size that is the sum of all merged volumes.
This size is unnecessarily big, since the volumes are in qcow2 format.

The fix should optimize the size of the new volume to be the minimal size used by the data on disk.

How reproducible:
100%

steps to reproduce:
1. create a vm with a thin provisioned disk.
2. create a snapshot
3. delete the snapshot
Comment 1 Yeela Kaplan 2012-12-17 10:29:35 EST
fix patch:

http://gerrit.ovirt.org/#/c/9725/
Comment 2 Ayal Baron 2012-12-17 17:55:05 EST
Fede, please add dependency on qemu-img bug as the above patch cannot be merged until qemu fully supports the required functionality.
Comment 5 Ayal Baron 2013-06-17 03:38:51 EDT
*** Bug 974124 has been marked as a duplicate of this bug. ***
Comment 8 Leonid Natapov 2013-08-14 05:40:44 EDT
is9.

5374bce1-906a-4389-bfdb-06d1cc00d442::DEBUG::2013-08-13 17:57:52,955::blockVolume::331::Storage.Volume::(shrinkToOptimalSize) Shrink qcow volume: d7700983-b3ca-42a3-88b6-5d20e4e51f35 to : 1073741824.0 bytes


vdsm-4.12.0-52.gitce029ba.el6ev.x86_64
qemu-kvm-rhev-tools-0.12.1.2-2.378.el6.x86_64
qemu-img-rhev-0.12.1.2-2.378.el6.x86_64
Comment 9 Charlie 2013-11-27 19:34:40 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 11:04:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.