This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 887991 - 18 Final TC3 x86_64 Design Suite Spin is > 1 GB
18 Final TC3 x86_64 Design Suite Spin is > 1 GB
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
AcceptedNTH
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-12-17 14:09 EST by Andre Robatino
Modified: 2014-03-16 23:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 23:56:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-12-17 14:09:52 EST
Description of problem:
Fedora-18-TC3-i686-Live-Design-suite.iso : 972029952 bytes (0.972 GB)
Fedora-18-TC3-x86_64-Live-Design-suite.iso : 1006632960 bytes (1.0066 GB)

According to https://fedoraproject.org/wiki/Releases/18/Spins the size limit is 1 GB = 1,000,000,000 bytes. The typical 1 GB thumb drive probably has sufficient extra space for this to fit (since the thumb drive originally has 1 GiB before some space is taken away for overhead) but still, 1 GB is the advertised size.

Version-Release number of selected component (if applicable):
18 Final TC3 Design Suite Spin
Comment 1 Adam Williamson 2012-12-17 15:21:58 EST
Accepted as NTH: we agreed at 2012-12-17 NTH review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-17/f18final-blocker-review-5.2012-12-17-16.40.log.txt - that over-size issues on non-blocking spins are accepted as NTH by policy without explicit discussion needed.
Comment 2 Bill Nottingham 2012-12-18 13:48:10 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=853590#c46
Comment 3 Andre Robatino 2013-01-03 09:10:30 EST
18 Final TC4 is slightly oversized again:

Fedora-18-TC4-i686-Live-Design-suite.iso : 974127104 bytes (0.974 GB)
Fedora-18-TC4-x86_64-Live-Design-suite.iso : 1004535808 bytes (1.0045 GB)
Comment 4 Bill Nottingham 2013-01-03 13:44:21 EST
Looking at the kickstart file, dropping gtk-recordmydesktop (in favor of the built in shell recorder) might be the simplest fix to free some space.
Comment 5 Sebastian Dziallas 2013-01-03 14:18:40 EST
I agree, that looks like a good way to fix it for now.

In general, I'm sorry this is coming up. I haven't spent much time in Fedora over the past year and I was under the impression that I had handed my projects off. Apparently my name is still in the kickstart file, though.

I'm wondering whether there's somebody who's willing to pick this up for the time being. I'll likely not have the cycles to carry it forward for quite a while. If nobody is willing to do that, it may make sense to not release this spin in the future.

Thoughts?
Comment 6 Bill Nottingham 2013-01-03 14:31:32 EST
OK, fixed in git. As for future incarnations on the spin... probably best to do that on the design team list or the spins list.
Comment 7 Andre Robatino 2013-01-06 01:40:54 EST
18 Final RC1 is slightly oversized:

Fedora-18-i686-Live-Design-suite.iso : 973078528 bytes (0.973 GB)
Fedora-18-x86_64-Live-Design-suite.iso : 1004535808 bytes (1.0045 GB)
Comment 8 Andre Robatino 2013-01-08 03:22:17 EST
18 Final RC2 is slightly oversized:

Fedora-18-i686-Live-Design-suite.iso : 973078528 bytes (0.973 GB)
Fedora-18-x86_64-Live-Design-suite.iso : 1004535808 bytes (1.0045 GB)
Comment 9 Luya Tshimbalanga 2013-01-08 12:47:32 EST
Hello, I recently took over Design Spin. Quick question, is it okay to replace some packages and remove them due to size?
Comment 10 Luya Tshimbalanga 2013-01-08 14:39:31 EST
After discussing with dgilmore, 1GB size applied for USB sticks but does not affect DVD. Perhaps changing the target to 2GB should do the trick inside:
https://fedoraproject.org/wiki/Releases/18/Spins
Comment 11 Adam Williamson 2013-01-08 17:28:19 EST
As the spin owner, the target size is entirely up to you (well, and anyone else you want to have input). It's the spin's own responsibility to consider its audience and how much space it 'needs' and pick an appropriate target size.

Common target sizes are 700MiB (precisely 734,003,200 bytes) (the largest standardized CD), 1GB ('next size up' from 700MiB - there are 1GB USB sticks available on the market), 4GiB (near to DVD size, and 4GiB is the largest file you can store on a FAT32 partition, so anything bigger than 4GiB cannot be downloaded to a Windows machine with only FAT32 partitions), and 4.7GB (precisely 4,700,000,000 bytes), the maximum safe size for writing to standard DVD formats. 2GB would be perfectly valid, though, and it's another size of USB stick that exists on the common market (USB stick sizes tend to go up in powers of 2, so 1GB, 2GB, 4GB, 8GB, 16GB, 32GB, 64GB, 128GB are current 'standard' sizes).

Note I'm differentiating between GB (power 10) and GiB (power 2) in the above, I believe USB stick sizes are usually GB not GiB.
Comment 12 Adam Williamson 2013-01-08 17:29:25 EST
As yours is a non-blocking spin, you don't _have_ to change your target size, or anything. You could keep your target size as 1GB, and just say 'sorry, we missed the size for F18, we'll try and get it back for F19'.
Comment 13 Andre Robatino 2013-01-08 22:22:24 EST
(In reply to comment #11)
> Common target sizes are 700MiB (precisely 734,003,200 bytes) (the largest
> standardized CD), 1GB ('next size up' from 700MiB - there are 1GB USB sticks
> available on the market), 4GiB (near to DVD size, and 4GiB is the largest
> file you can store on a FAT32 partition, so anything bigger than 4GiB cannot
> be downloaded to a Windows machine with only FAT32 partitions), and 4.7GB

To be super nit-picky, the FAT file size limit is actually 4 GiB - 1 byte (in https://fedoraproject.org/wiki/Releases/18/Spins I was careful to distinguish between < and <= ). I note that Luya has already changed the Design Suite size on that page to 2 GB, so if that holds this bug could just be closed.
Comment 14 Adam Williamson 2013-01-08 22:24:13 EST
also, we're doing an RC3 to add in the final release notes, so if someone wanted to slip in a change to cut a package out of design suite and get it under 1GB, that would also work. you've got an hour or two.
Comment 15 Luya Tshimbalanga 2013-01-08 23:36:05 EST
Setting the size to 2GB will do the trick and I intend to increase to 4GB in next release (F19). This bug can be closed.
Comment 16 Andre Robatino 2013-01-08 23:56:15 EST
Closing since the current size limit is 2 GB.

Note You need to log in before you can comment on or make changes to this bug.