Bug 888007 - logwatch a bit chatty with smartd
Summary: logwatch a bit chatty with smartd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch
Version: 6.3
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: Ondrej Hudlicky
URL:
Whiteboard:
Depends On:
Blocks: 1162741
TreeView+ depends on / blocked
 
Reported: 2012-12-17 19:58 UTC by jcpunk
Modified: 2014-11-11 15:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1162741 (view as bug list)
Environment:
Last Closed: 2013-09-10 13:40:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch (10.66 KB, patch)
2013-06-06 08:03 UTC, Jan Synacek
no flags Details | Diff
Patch (1.35 KB, patch)
2013-06-06 12:04 UTC, Jan Synacek
no flags Details | Diff
Reproducer (628 bytes, application/x-sh)
2013-06-06 12:14 UTC, Jan Synacek
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1247 0 normal SHIPPED_LIVE logwatch bug fix update 2013-09-10 17:38:05 UTC

Description jcpunk 2012-12-17 19:58:08 UTC
Description of problem: the logwatch summary of the smartd logs contains a few extra lines:

 **Unmatched Entries**
 smartd 5.42 2011-10-20 r3458 [x86_64-linux-2.6.32-279.14.1.el6.x86_64] (local build)
 Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net
 Device: /dev/sda, type changed from 'scsi' to 'sat'
 Device: /dev/sdb, type changed from 'scsi' to 'sat'
 Device: /dev/sdc, type changed from 'scsi' to 'sat'
 Device: /dev/sda [SAT], previous self-test completed without error
 Device: /dev/sdb [SAT], previous self-test completed without error
 Device: /dev/sdc [SAT], previous self-test completed without error

The current upstream version 7.4.0 does not have this behavior.


Version-Release number of selected component (if applicable):logwatch-7.3.6-49.el6


How reproducible: 100%


Steps to Reproduce:
1. restart smartd
2. run logwatch
3. read output
  
Actual results:
messages that can be filtered out are not


Expected results:
filtered messages


Additional info:

Comment 3 Jan Synacek 2013-01-09 10:57:05 UTC
I've built a new package containing an updated smartd script.

http://people.redhat.com/jsynacek/logwatch/logwatch-7.3.6-50.el6.noarch.rpm (testing only)

Could you please test it?

Comment 4 jcpunk 2013-01-09 19:55:16 UTC
works for me

Comment 6 Jan Synacek 2013-06-06 08:03:44 UTC
Created attachment 757538 [details]
Patch

Comment 8 Jan Synacek 2013-06-06 12:04:44 UTC
Created attachment 757641 [details]
Patch

Minimal patch

Comment 9 Jan Synacek 2013-06-06 12:14:25 UTC
Created attachment 757645 [details]
Reproducer

Reproducer

How to test:
1) sh test.sh
2 - before) output with **Unmatched Entries**
2 - after) no output

Comment 14 errata-xmlrpc 2013-09-10 13:40:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1247.html


Note You need to log in before you can comment on or make changes to this bug.