Bug 88829 - Anaconda (installer) crashes when reading package information
Summary: Anaconda (installer) crashes when reading package information
Status: CLOSED DUPLICATE of bug 75008
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-14 18:09 UTC by Need Real Name
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-04-14 18:09:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
I just can't upgrade my RH 8 to 9. I haven't tried fresh install-option. I've
tried EVERY option prior crash (not so many, text-install, different mouse
types, bootloader options..). The mediacheck is PASS and md5sums are correct.
The most important point here is that I've installed with these CD's to other
computers so the problem is related to my 8.0 install and the installer. I've
uninstalled all the Ximian packages. The installer crashes soon after "Reading
package information" and a pop-up pops suggesting to save the dump.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Choose language (english)
2. Choose keyboard (Finnish, latin1)
3. Choose bootloader option
4. Choose upgrade and customize packages (or not)
   

Actual Results:  Installer starts to examine the packages installed and crashes
with the text "This is most likely a bug ..." and suggests to take the dump and
forward it to Bugzilla.

Expected Results:  1 hour of upgrading ;)

Additional info:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 739, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 459, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 331, in upgradeFindPackages
    method.mergeFullHeaders(id.hdList)
  File "/usr/lib/anaconda/image.py", line 50, in mergeFullHeaders
    hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
  File "/usr/lib/anaconda/comps.py", line 180, in mergeFullHeaders
    rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
IndexError: list index out of range

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 0x87793ec>
fd: 36
file: /mnt/source/RedHat/base/hdlist2   ...

Comment 1 Michael Fulbright 2003-04-15 16:11:46 UTC
If you look on VC4 (cntl-alt-f4) when this error occurs do you see any error
messages from the kernel about read errors from the CD?

This is definately a CD related issue. It either the drive or the media or the
combination.  CDs are known to pass the mediacheck and fail later if they are
just borderline.


Comment 2 Need Real Name 2003-04-15 17:09:25 UTC
Yes, the screen is full of error messages related to CD (or hdc). Just a few
lines but the rest is quite the same.

<4> end_request: I/O error, dev 16:00 (hdc), sector 1064660
<4>: cdrom_decode_status: status=0x51 {DriveReadySeekComplete Error}
<4>: cdrom_decode_status: error = 0x30 LastFailedSense 0x30

Comment 3 Michael Fulbright 2003-04-21 21:52:01 UTC
Those are CD read errors.  I would recommend trying a diffrent CD drive in the
machine or burning the images on a different brand of media.

*** This bug has been marked as a duplicate of 75008 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.