Bug 888295 - SAM Cli : 'config_template' command should not be in headpin
SAM Cli : 'config_template' command should not be in headpin
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Jordan OMara
Tazim Kolhar
: Triaged
: 886750 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-12-18 08:12 EST by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:54:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2012-12-18 08:12:41 EST
Description of problem:

headpin cli should not include config_template command.

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-selinux-1.2.1-1h.el6_3.noarch
katello-cli-1.2.4-4h.el6_3.noarch
katello-headpin-1.2.6-6h.el6_3.noarch
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.2.3-1h.el6_3.noarch
katello-common-1.2.6-6h.el6_3.noarch
katello-headpin-all-1.2.6-6h.el6_3.noarch
katello-glue-candlepin-1.2.6-6h.el6_3.noarch
katello-cli-common-1.2.4-4h.el6_3.noarch


How reproducible:

# yum install -y katello-headpin-all
# katello-configure --deployment=sam

Steps to Reproduce:

1.# headpin -u admin -p admin config_template --help
Usage:  headpin <options> config_template <command>
Supported Commands:
	build_pxe_default build pxe default
	create         create config template
	delete         delete config template
	info           show information about a config template
	list           list config template
	update         update config template

Options:
  -h, --help  show this help message and exit


  
Actual results:

possible options for the command is displayed

Expected results:

the command is not supposed to be included in headpin

Additional info:
Comment 1 Tom McKay 2012-12-18 09:31:05 EST
*** Bug 886750 has been marked as a duplicate of this bug. ***
Comment 2 Bryan Kearney 2013-06-07 10:48:15 EDT
Usage:  headpin <options> <command>
Supported Commands:
	activation_key activation key specific actions in the katello server
	client         client specific actions in the katello server
	distributor    distributor specific actions in the katello server
	environment    environment specific actions in the katello server
	org            organization specific actions in the katello server
	permission     permission specific actions in the katello server
	ping           get the status of the katello server
	product        product specific actions in the katello server
	provider       provider specific actions in the katello server
	shell          run the cli as a shell
	system         system specific actions in the katello server
	system_group   system group specific actions in the katello server
	user           user specific actions in the katello server
	user_role      user role specific actions in the katello server
	version        get the version of the katello server
Comment 3 Tazim Kolhar 2013-08-08 07:41:09 EDT
VERIFIED :

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch

# headpin -u admin -p admin --help
Usage:  headpin <options> <command>
Supported Commands:
	about          status of the katello server and its subcomponents
	activation_key activation key specific actions in the katello server
	client         client specific actions in the katello server
	distributor    distributor specific actions in the katello server
	environment    environment specific actions in the katello server
	org            organization specific actions in the katello server
	permission     permission specific actions in the katello server
	ping           get the status of the katello server
	product        product specific actions in the katello server
	provider       provider specific actions in the katello server
	shell          run the cli as a shell
	system         system specific actions in the katello server
	system_group   system group specific actions in the katello server
	user           user specific actions in the katello server
	user_role      user role specific actions in the katello server
	version        get the version of the katello server
Comment 5 errata-xmlrpc 2013-10-01 06:54:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.