Bug 888492 - Business model polling continues after logging out.
Summary: Business model polling continues after logging out.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3
Assignee: Alexander Wels
QA Contact:
URL:
Whiteboard: ux
Depends On:
Blocks: 947515
TreeView+ depends on / blocked
 
Reported: 2012-12-18 19:18 UTC by Alexander Wels
Modified: 2013-09-23 07:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 947515 (view as bug list)
Environment:
Last Closed: 2013-09-23 07:32:52 UTC
oVirt Team: ---


Attachments (Terms of Use)
Screenshot of the POSTs happening. (132.24 KB, image/png)
2012-12-18 19:18 UTC, Alexander Wels
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 10895 None None None Never
oVirt gerrit 12023 None None None Never

Description Alexander Wels 2012-12-18 19:18:03 UTC
Created attachment 665733 [details]
Screenshot of the POSTs happening.

Description of problem:
When you log out of the web admin portal the automatic refresh of the business models on your last active tab does not stop. If you look at the firebug net tab while logged in you will see POSTs to GenericAPIGWTService to refresh the business models. When you log out, the POSTs do not stop.

Version-Release number of selected component (if applicable):
3.2

How reproducible:
I can reproduce every single time.

Steps to Reproduce:
1. Log into the web admin portal.
2. Open up firebug on the net tab. See the POSTs to GenericAPIGWTService.
3. Log out of the portal.
4. See more POSTs to GenericAPIGWTService.
  
Actual results:
POSTs to GenericAPIGWTService.

Expected results:
No AJAX calls to the server from the browser when logged out.

Additional info:

Comment 1 Vojtech Szocs 2013-01-04 14:06:09 UTC
After the user signs out of Web Admin, CommonModel.SignOut() should stop refresh timers on all related models via EnsureAsyncSearchStopped() method. Need to investigate why the currently selected model doesn't have its timer stopped. This issue should be fixed in CommonModel.SignOut() before SignedOutEvent is triggered by CommonModel.

As part of fixing this issue, we should also remove code that hides error dialog on Frontend errors within login section, as it was meant to guard against the case of models making queries which fail due to the user no longer signed in:
- consider removing FrontendFailureEventListener.hide() method, and code which calls it
- consider removing ErrorPopupManager.setShowPopups() method, and code which calls it

Comment 2 Alexander Wels 2013-01-10 20:15:01 UTC
It turns out the following entities where not being stopped:

- BookmarkList
- RoleListModel
- SystemPermissionListModel

Comment 3 Alexander Wels 2013-01-10 20:48:48 UTC
Patchset is available here:
http://gerrit.ovirt.org/10895

Comment 4 Itamar Heim 2013-08-21 16:40:31 UTC
as RC is built, moving to ON_QA (hopefully did not catch incorrect bugs when doing this)

Comment 5 Itamar Heim 2013-09-23 07:32:52 UTC
closing as this should be in 3.3 (doing so in bulk, so may be incorrect)


Note You need to log in before you can comment on or make changes to this bug.