Bug 88858 - redhat-control-network:382:hydrate:AttributeError
redhat-control-network:382:hydrate:AttributeError
Status: CLOSED DUPLICATE of bug 82805
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 106316 (view as bug list)
Depends On: 82805
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 21:01 EDT by Joshua Lee
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Lee 2003-04-14 21:01:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I was dialing my ISP, metconnect. After several busy signals and redials I was
about to change the number, so I tried to abort. After several attempts I closed
the program, but I heard my modem connect and it connected successfully to the
internet while it was closed. I got the automatic bug report then; a paste of
which is bellow.

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Didn't try

Steps to Reproduce:
1.dial ISP
2.redial, and redial again and decide to call it off for now, so with difficulty
close "network device controll."
3. connection succeeds with network device control (apparantly, but apparantly
not really) closed.
4. crash occurs, without taking down ppp connection.    

Actual Results:  crash occurs, but without affecting successful ppp connection
to dialup ISP.

Expected Results:  same except no crash.

Additional info:

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/bin/redhat-control-network:382:hydrate:AttributeError:
'NoneType' object has no attribute 'clear'
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 183, in on_activateButton_clicked
   self.update_dialog()
  File "/usr/bin/redhat-control-network", line 503, in update_dialog
    self.hydrate()
  File "/usr/bin/redhat-control-network", line 382, in hydrate
    clist.clear()
AttributeError: 'NoneType' object has no attribute 'clear'
 
Local variables in innermost frame:
clist: None
plist: None
self: <__main__.mainDialog instance at 0x852dc74>
Comment 1 Harald Hoyer 2003-04-15 04:16:41 EDT
very strange... did you kill the GUI Window of redhat-control-network?
Comment 2 Joshua Lee 2003-04-15 08:10:08 EDT
No, I didn't use kill. I clicked on the x box in the window corner.
Comment 3 Harald Hoyer 2003-04-15 08:21:39 EDT
then, there is not much I can do about it, other than providing a
"Cancel"-Button for the Activation Dialog
Comment 4 Joshua Lee 2003-04-15 19:47:10 EDT
That sounds like a bit of a hack, but if it works maybe it'd be a good idea.
Really the ideal behavior would be to abort the dialing when the window is
closed. wvdial if it recieves a signal does this, for example.
Comment 5 Harald Hoyer 2003-04-16 04:12:39 EDT
this is my plan... as soon as the dialog is killed or cancel pressed, then kill
-15 for the dialing process..
Comment 6 Joshua Lee 2003-04-16 12:33:20 EDT
That sounds good. Thanks for your help.
Comment 7 Harald Hoyer 2003-04-16 12:36:16 EDT
thx for your suggestions... that was just the thing I implemented today :)
Comment 8 Harald Hoyer 2003-04-17 06:33:10 EDT

*** This bug has been marked as a duplicate of 82805 ***
Comment 9 Harald Hoyer 2003-10-24 11:54:51 EDT
*** Bug 106316 has been marked as a duplicate of this bug. ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:52:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.