Bug 888795 - When Installing python-novaclient, The package python-iso8601 should be installed by dependency.
When Installing python-novaclient, The package python-iso8601 should be insta...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
2.0 (Folsom)
Unspecified Linux
unspecified Severity high
: snapshot2
: 2.1
Assigned To: Alan Pevec
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 08:53 EST by Nir Magnezi
Modified: 2013-02-14 13:24 EST (History)
1 user (show)

See Also:
Fixed In Version: python-novaclient-2.10.0-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 13:24:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nir Magnezi 2012-12-19 08:53:27 EST
Description of problem:
=======================
Used packstack to install openstack.
The issue was found in the host I used as OSCLIENT_HOST.

Version-Release number of selected component (if applicable):
=============================================================
Folsom.
Packstack Ver: openstack-packstack-2012.2.2-0.1.dev248.el6.noarch
python-novaclient-2.10.0-1.el6ost.noarch

How reproducible:
=================
100%


Steps to Reproduce:
===================
1. Use openstack-packstack-2012.2.2-0.1.dev248.el6.noarch
2. generate an answer file for packstack:

# packstack --answer-file=ans.txt

3. set CONFIG_OSCLIENT_HOST to a host and don't use that host for any other openstack component (meaning it will be used a client only)
4. install openstack

# packstack --answer-file=ans_new.txt

5. connect (via ssh) to the host you set as CONFIG_OSCLIENT_HOST
6.  # source ~/keystonerc_admin
7.  # nova list 


Actual results:
===============

Traceback (most recent call last):
  File "/usr/bin/nova", line 9, in <module>
    load_entry_point('python-novaclient==2.10.0', 'console_scripts', 'nova')()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 299, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2229, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1948, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.6/site-packages/novaclient/shell.py", line 37, in <module>
    from novaclient.v1_1 import shell as shell_v1_1
  File "/usr/lib/python2.6/site-packages/novaclient/v1_1/shell.py", line 27, in <module>
    from novaclient.openstack.common import timeutils
  File "/usr/lib/python2.6/site-packages/novaclient/openstack/common/timeutils.py", line 25, in <module>
    import iso8601
ImportError: No module named iso8601


Expected results:
=================
A list of running instances.
Comment 2 Eoghan Glynn 2012-12-20 08:44:35 EST
Looks like we're implicitly depending on the {nova|glance}client being installed on the same host as {nova|glance}, as the latter packages both have explicit dependencies on python-iso8601:

  https://github.com/fedora-openstack/openstack-nova/blob/master/openstack-nova.spec#L275
  https://github.com/fedora-openstack/openstack-glance/blob/master/openstack-glance.spec#L52

These dependencies should be added to the openstack-python-{nova|glance}client .spec files also.
Comment 3 Alan Pevec 2012-12-21 03:41:06 EST
Fedora 18 bug 881515
Comment 5 Nir Magnezi 2013-02-04 07:47:33 EST
Reopening the bug.
Following to Comment #2 I tried to verify this bug as follows.

1. Checked that python-novaclient install python-iso8601 by dependency.

$ yum install python-novaclient
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-novaclient.noarch 1:2.10.0-2.el6ost will be installed
--> Processing Dependency: python-iso8601 for package: 1:python-novaclient-2.10.0-2.el6ost.noarch
--> Running transaction check
---> Package python-iso8601.noarch 0:0.1.4-2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                             Arch                                     Version                                              Repository                                                 Size
===================================================================================================================================================================================================================
Installing:
 python-novaclient                                   noarch                                   1:2.10.0-2.el6ost                                    packstack_0                                               148 k
Installing for dependencies:
 python-iso8601                                      noarch                                   0.1.4-2.el6                                          OpenStack-Folsom-Puddle                                    11 k

Transaction Summary
===================================================================================================================================================================================================================
Install       2 Package(s)

Tested OK.


2.  Checked that python-glanceclient install python-iso8601 by dependency.

$ yum install python-keystoneclient
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-keystoneclient.noarch 1:0.1.3.27-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                                Arch                                    Version                                             Repository                                                Size
===================================================================================================================================================================================================================
Installing:
 python-keystoneclient                                  noarch                                  1:0.1.3.27-1.el6                                    OpenStack-Folsom-Puddle                                   67 k

Transaction Summary
===================================================================================================================================================================================================================
Install       1 Package(s)


python-iso8601 is missing here.

Repo: 2013-02-01.1
Comment 6 Alan Pevec 2013-02-04 08:06:17 EST
(In reply to comment #5)
> Reopening the bug.
> Following to Comment #2 I tried to verify this bug as follows.

comment 2 is wrong, glanceclient does _not_ have dep on iso8601:
$ grep -r iso8601 python-glanceclient-0.5.1/; echo $?
1

> 2.  Checked that python-glanceclient install python-iso8601 by dependency.
...
> python-iso8601 is missing here.

It is not - also these are two separate components so file separate BZs files.
Comment 7 Yaniv Kaul 2013-02-10 10:49:39 EST
Verified:
[root@cougar10 _base]# rpm -qR python-novaclient |grep iso8601
python-iso8601  
[root@cougar10 _base]# rpm -q python-novaclient
python-novaclient-2.10.0-2.el6ost.noarch
Comment 9 errata-xmlrpc 2013-02-14 13:24:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html

Note You need to log in before you can comment on or make changes to this bug.