Bug 888812 - We should alert user from installing nova-mange (network ) incase quantum is going to be installed
We should alert user from installing nova-mange (network ) incase quantum is ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Getting_Started_Guide (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Stephen Gordon
ecs-bugs
: Documentation, Triaged
: 858276 889871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 09:56 EST by Ofer Blaut
Modified: 2016-04-26 09:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack-Getting_Started_Guide-2-web-en-US-1.0-22.el6eng
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 14:39:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2012-12-19 09:56:17 EST
Description of problem:

User guide doesn't include special section for Nova network in Section 6 ( Nova compute )

We should alert user from installing nova-mange (network) see line below ,incase quantum is going to be installed 

it will conflict with quantum installation.

$ sudo nova-manage network create demonet 10.0.0.0/24 1 256 --bridge=demonetbr0"


Version-Release number of selected component (if applicable):

"Getting Started with OpenStack Folsom Preview

Edition 1.0"

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Matthias Runge 2012-12-20 04:46:41 EST
And also, if we encourage users to take quantum instead of nova-network, then we should update exercises to use quantum instead of nova network for e.g. floating ips
Comment 3 Perry Myers 2012-12-20 17:45:52 EST
I think we need parallel sections.  Basically a getting started guide that assumes Nova Networking and a getting started guide that assumes Quantum networking.

Hopefully the differences between these two paths can be isolated to a few sections, vs. needing two separate documents.
Comment 5 Stephen Gordon 2013-01-16 11:47:01 EST
*** Bug 889871 has been marked as a duplicate of this bug. ***
Comment 6 Stephen Gordon 2013-01-16 11:47:34 EST
*** Bug 858276 has been marked as a duplicate of this bug. ***
Comment 7 Stephen Gordon 2013-01-16 11:49:38 EST
To ensure proper coverage here we need to provide:

1) Accurate documentation for using Nova networking.

2) Accurate documentation for using Quantum networking.

3) Contrast between the two (pros/cons) and guidance *not* to use both at the same time.

It is unclear based on the comments so far that there is a specific preference for RHOS users to use one over the other so in the meantime we need to treat both as equal citizens.
Comment 8 Stephen Gordon 2013-02-12 15:17:45 EST
I've added this "important" admonition:

"Red Hat OpenStack compute services also support networking using the OpenStack Network Service. If you wish to use the OpenStack Network Service to provide networking services to your compute instances then do not create a network using the nova-manage command."
Comment 9 Stephen Gordon 2013-02-12 15:18:27 EST
commit fcac794de9bcfd5e37efcd98bf891dd7c4eaf4bb
Author: Stephen Gordon <sgordon@redhat.com>
Date:   Tue Feb 12 15:16:24 2013 -0500

    BZ#888812 - Users wishing to use ONS should not use nova-manage to create network.
    
    Added an admonition advising users wishing to use the OpenStack
    Network Service for instance networking not to create a network
    using nova-manage.
Comment 10 Stephen Gordon 2013-02-13 09:22:02 EST
Moving back to assigned as the nova-network service(s) must also be stopped and the compute services restarted.
Comment 12 Stephen Gordon 2013-02-13 14:59:24 EST
commit fdb0453989888a6e875f6ca85c592edf9d1e2aac
Author: Stephen Gordon <sgordon@redhat.com>
Date:   Wed Feb 13 14:56:40 2013 -0500

    BZ#888812 - Updated instructions for avoiding Nova network when planning to use ONS
    
    For users wishing to use the OpenStack network service instead of the Nova
    network service made the following changes:
    
    - Added instruction to skip start of openstack-nova-network service in Nova chapter.
    - Added instruction to skip nova-manage network create in Nova chapter.
    - Added instruction to OpenStack Network chapter specifying the Nova service to restart once
      the node is configured for OpenStack Network.
Comment 13 Stephen Gordon 2013-02-15 10:43:01 EST
Moving back to assigned, I missed a word and made a spelling mistake here. The admonition currently reads:

"Do not use the service or chkconfig commands to start the openstack-nova-network if you intend to install and configure the OpenStack Network service to manage the networking for your enviornment."

Need to add the work service after openstack-nova-network and spell environment correctly.
Comment 16 Ofer Blaut 2013-02-27 02:16:42 EST
I have checked the comments on the docs

Note You need to log in before you can comment on or make changes to this bug.