Bug 888998 - AttributeError: 'NoneType' object has no attribute 'removeMember'
AttributeError: 'NoneType' object has no attribute 'removeMember'
Status: CLOSED DUPLICATE of bug 889101
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:381fc8f7cdbdba1bc4a6d3d2dca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 19:34 EST by Chris Murphy
Modified: 2012-12-20 04:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 04:30:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (961.44 KB, text/plain)
2012-12-19 19:35 EST, Chris Murphy
no flags Details
File: anaconda.log (40.72 KB, text/plain)
2012-12-19 19:35 EST, Chris Murphy
no flags Details
File: environ (873 bytes, text/plain)
2012-12-19 19:35 EST, Chris Murphy
no flags Details
File: ifcfg.log (379 bytes, text/plain)
2012-12-19 19:35 EST, Chris Murphy
no flags Details
File: messages (176.72 KB, text/plain)
2012-12-19 19:35 EST, Chris Murphy
no flags Details
File: program.log (44.11 KB, text/plain)
2012-12-19 19:35 EST, Chris Murphy
no flags Details
File: storage.log (681.82 KB, text/plain)
2012-12-19 19:35 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-12-19 19:34:59 EST
Description of problem:
1. Selected eight new virtual disks.
2. Manual Partitioning.
3. Added a swap mp, specified a particular drive for it to be on.
4. Added a /boot mp, specified a particular drive for it to be on.
5. Added a / mp, specified all other drives for that to be created on (not on the disk for /boot or swap), and to make it a RAID 0 of 7 drives.
6. While trying to figure out why the UI was telling me only 5 GB were free for each remaining 8 GB virtual disk, all of that clicking around ended up in a crash.
The following was filed automatically by anaconda:
anaconda 18.37.3 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1900, in setContainerMembers
    container.removeMember(member)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2155, in newDevice
    members=members, device=device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1171, in _save_right_side
    raid_level=raid_level)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2120, in on_selector_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 195, in _onSelectorClicked
    cb(selector)
AttributeError: 'NoneType' object has no attribute 'removeMember'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-18-TC3-x86_64-Live-Deskto rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.3-1.fc18.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 18 (Spherical Cow)
type:           libreport
version:        18
Comment 1 Chris Murphy 2012-12-19 19:35:03 EST
Created attachment 666459 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2012-12-19 19:35:05 EST
Created attachment 666460 [details]
File: anaconda.log
Comment 3 Chris Murphy 2012-12-19 19:35:07 EST
Created attachment 666461 [details]
File: environ
Comment 4 Chris Murphy 2012-12-19 19:35:08 EST
Created attachment 666462 [details]
File: ifcfg.log
Comment 5 Chris Murphy 2012-12-19 19:35:10 EST
Created attachment 666463 [details]
File: messages
Comment 6 Chris Murphy 2012-12-19 19:35:12 EST
Created attachment 666464 [details]
File: program.log
Comment 7 Chris Murphy 2012-12-19 19:35:15 EST
Created attachment 666465 [details]
File: storage.log
Comment 8 Chris Murphy 2012-12-20 04:30:43 EST
Appears to be the same bug as bug 889101, although this bug's crash occurs from a click OTHER than clicking the Apply Changes button.

*** This bug has been marked as a duplicate of bug 889101 ***

Note You need to log in before you can comment on or make changes to this bug.