Bug 889101 - AttributeError: 'NoneType' object has no attribute 'removeMember'
AttributeError: 'NoneType' object has no attribute 'removeMember'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:5a7ec61c217f03a336f867acb61...
:
: 888998 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-20 03:51 EST by Chris Murphy
Modified: 2013-01-02 16:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 16:49:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (745.99 KB, text/plain)
2012-12-20 03:51 EST, Chris Murphy
no flags Details
File: anaconda.log (26.84 KB, text/plain)
2012-12-20 03:51 EST, Chris Murphy
no flags Details
File: environ (873 bytes, text/plain)
2012-12-20 03:51 EST, Chris Murphy
no flags Details
File: ifcfg.log (379 bytes, text/plain)
2012-12-20 03:51 EST, Chris Murphy
no flags Details
File: messages (164.28 KB, text/plain)
2012-12-20 03:51 EST, Chris Murphy
no flags Details
File: program.log (44.11 KB, text/plain)
2012-12-20 03:51 EST, Chris Murphy
no flags Details
File: storage.log (492.67 KB, text/plain)
2012-12-20 03:51 EST, Chris Murphy
no flags Details
anaconda-tb-hPD7MJ (467.89 KB, text/plain)
2012-12-20 04:25 EST, Chris Murphy
no flags Details
anaconda.log (19.91 KB, text/plain)
2012-12-20 04:26 EST, Chris Murphy
no flags Details
program.log (43.13 KB, text/plain)
2012-12-20 04:27 EST, Chris Murphy
no flags Details
storage.log (246.83 KB, text/plain)
2012-12-20 04:27 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-12-20 03:51:17 EST
Description of problem:
1. Manual Partitioning.
2. Set swap and /boot to be on sda in Configure Mount Point.
3. Create /, set to RAID 0, go to Configure Mount Point and choose 7 of 8 disks (not the 1 used for swap and /boot).
4. Clicked Apply.
Crash.
The following was filed automatically by anaconda:
anaconda 18.37.3 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1900, in setContainerMembers
    container.removeMember(member)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2155, in newDevice
    members=members, device=device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1171, in _save_right_side
    raid_level=raid_level)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2434, in on_apply_clicked
    self._save_right_side(self._current_selector)
AttributeError: 'NoneType' object has no attribute 'removeMember'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-18-TC3-x86_64-Live-Deskto rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.3-1.fc18.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 18 (Spherical Cow)
type:           libreport
version:        18
Comment 1 Chris Murphy 2012-12-20 03:51:23 EST
Created attachment 666543 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2012-12-20 03:51:24 EST
Created attachment 666544 [details]
File: anaconda.log
Comment 3 Chris Murphy 2012-12-20 03:51:26 EST
Created attachment 666545 [details]
File: environ
Comment 4 Chris Murphy 2012-12-20 03:51:28 EST
Created attachment 666546 [details]
File: ifcfg.log
Comment 5 Chris Murphy 2012-12-20 03:51:29 EST
Created attachment 666547 [details]
File: messages
Comment 6 Chris Murphy 2012-12-20 03:51:31 EST
Created attachment 666548 [details]
File: program.log
Comment 7 Chris Murphy 2012-12-20 03:51:33 EST
Created attachment 666549 [details]
File: storage.log
Comment 8 Chris Murphy 2012-12-20 04:22:36 EST
Easier to reproduce and more realistic. 3 disks, 1 is for /boot and swap as Standard Partitions. 2 disks are RAID 0 for / alone.

1. Installation Options > Partition Scheme Configuration to Standard Partition, and check "let me customize."

2. Add new mount point, /boot, 500MB, add.
3. Add new mount point, swap, 5GB, add.
At this point /boot and swap are on /dev/sda which is fine.
4. Add new mount point, /, 5M, add. 
I'm disallowed from specifying the actual desired size, because I haven't yet informed the UI that I want this device to be RAID 0, but whether the size is tiny like 5M, or close to desired like 15GB, doesn't matter.
5. Change the Device Type of Root to RAID 0.
6. Configuration Options for Root, to make sure it's using only sdb and sdc.
7. Click apply.

Crash.

Component Version:
anaconda-18.37.4-1

Proposing as a blocker:
Fedora 18 Beta Criterion #11 "The installer must be able to create and install to software, hardware or BIOS RAID-0, RAID-1 or RAID-5 partitions for anything except /boot."
Comment 9 Chris Murphy 2012-12-20 04:25:39 EST
Created attachment 666555 [details]
anaconda-tb-hPD7MJ

anaconda-tb-hPD7MJ from crash reproduced following comment 8 steps.
Comment 10 Chris Murphy 2012-12-20 04:26:31 EST
Created attachment 666556 [details]
anaconda.log

from crash reproduced following comment 8 steps.
Comment 11 Chris Murphy 2012-12-20 04:27:04 EST
Created attachment 666557 [details]
program.log

program.log from crash reproduced following comment 8 steps.
Comment 12 Chris Murphy 2012-12-20 04:27:41 EST
Created attachment 666558 [details]
storage.log

storage.log from crash reproduced following comment 8 steps.
Comment 13 Chris Murphy 2012-12-20 04:30:43 EST
*** Bug 888998 has been marked as a duplicate of this bug. ***
Comment 14 David Lehman 2012-12-20 23:23:24 EST
FWIW I have tested a patch for this.
Comment 15 Adam Williamson 2012-12-21 13:50:15 EST
Discussed at 2012-12-21 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-21/f18final-blocker-review-7.2012-12-21-18.33.log.txt . Accepted as a blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above"
Comment 16 Fedora Update System 2012-12-21 18:32:48 EST
dracut-024-17.git20121220.fc18, anaconda-18.37.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20838/dracut-024-17.git20121220.fc18,anaconda-18.37.7-1.fc18
Comment 17 Fedora Update System 2012-12-22 16:11:16 EST
Package dracut-024-17.git20121220.fc18, anaconda-18.37.8-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-024-17.git20121220.fc18 anaconda-18.37.8-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20838/dracut-024-17.git20121220.fc18,anaconda-18.37.8-1.fc18
then log in and leave karma (feedback).
Comment 18 Chris Murphy 2012-12-23 17:58:56 EST
Appears to be fixed, cannot reproduce.
Comment 19 Fedora Update System 2013-01-02 16:49:53 EST
dracut-024-17.git20121220.fc18, anaconda-18.37.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.