Bug 889382 - Glusterd crashes in volume delete
Glusterd crashes in volume delete
Status: CLOSED DUPLICATE of bug 893851
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Avra Sengupta
:
: 892985 (view as bug list)
Depends On:
Blocks: 895528
  Show dependency treegraph
 
Reported: 2012-12-20 21:36 EST by Pranith Kumar K
Modified: 2013-01-22 07:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 07:29:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-12-20 21:36:24 EST
Description of problem:
Program terminated with signal 11, Segmentation fault.
#0  0x00007f2ae6c05fee in glusterd_op_ac_send_lock (event=0x7f2ad81e3ee0, ctx=0x0)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:2144
2144	                if (!peerinfo->connected || !peerinfo->mgmt)
Missing separate debuginfos, use: debuginfo-install device-mapper-event-libs-1.02.74-10.el6_3.2.x86_64 device-mapper-libs-1.02.74-10.el6_3.2.x86_64 glibc-2.12-1.80.el6_3.5.x86_64 keyutils-libs-1.4-4.el6.x86_64 krb5-libs-1.9-33.el6_3.3.x86_64 libcom_err-1.41.12-12.el6.x86_64 libgcc-4.4.6-4.el6.x86_64 libselinux-2.0.94-5.3.el6.x86_64 libsepol-2.0.41-4.el6.x86_64 libudev-147-2.42.el6.x86_64 libxml2-2.7.6-8.el6_3.3.x86_64 lvm2-libs-2.02.95-10.el6_3.2.x86_64 openssl-1.0.0-25.el6_3.1.x86_64 zlib-1.2.3-27.el6.x86_64
(gdb) bt
#0  0x00007f2ae6c05fee in glusterd_op_ac_send_lock (event=0x7f2ad81e3ee0, ctx=0x0)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:2144
#1  0x00007f2ae6c0dcbf in glusterd_op_sm () at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:5373
#2  0x00007f2ae6c53386 in glusterd_handle_cli_delete_volume (req=0x7f2ae582802c)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-volume-ops.c:422
#3  0x00007f2aeafe32fc in synctask_wrap (old_task=0x21bbde0) at /var/lib/jenkins/jobs/smoke/workspace/libglusterfs/src/syncop.c:129
#4  0x00007f2aea252b80 in ?? () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()
(gdb) fr 0
#0  0x00007f2ae6c05fee in glusterd_op_ac_send_lock (event=0x7f2ad81e3ee0, ctx=0x0)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:2144
2144	                if (!peerinfo->connected || !peerinfo->mgmt)
(gdb) p peerinfo 
$1 = (glusterd_peerinfo_t *) 0x4


Version-Release number of selected component (if applicable):


How reproducible:
1/1

Steps to Reproduce:
This happened while running regression script for my patch
http://review.gluster.org/#change,4310 which has nothing to do with glusterd.
Here is the test case file that failed.
[11:06:13] ./tests/bugs/bug-879490.t ......... 
not ok 12 
Failed 1/13 subtests 

For full log check http://build.gluster.org/job/regression/299/console
Actual results:


Expected results:


Additional info:
Comment 1 Amar Tumballi 2013-01-08 07:08:09 EST
*** Bug 892985 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Darcy 2013-01-22 07:29:46 EST
Given the time frame and the "weird" symptoms, marking as a dup of a memory-corruption bug that existed at that time.

*** This bug has been marked as a duplicate of bug 893851 ***

Note You need to log in before you can comment on or make changes to this bug.