Bug 892985 - Crash in glusterd during volume delete
Crash in glusterd during volume delete
Status: CLOSED DUPLICATE of bug 889382
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 06:20 EST by Vijay Bellur
Modified: 2015-11-03 18:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 07:08:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2013-01-08 06:20:34 EST
Description of problem:

While running test bug-879490.t, the following crash is seen:

Core was generated by `glusterd'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007f21e88be022 in glusterd_op_ac_send_lock (event=0x7f21d819eff0, ctx=0x0)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:2144
2144	                if (!peerinfo->connected || !peerinfo->mgmt)
Missing separate debuginfos, use: debuginfo-install device-mapper-event-libs-1.02.74-10.el6_3.2.x86_64 device-mapper-libs-1.02.74-10.el6_3.2.x86_64 glibc-2.12-1.80.el6_3.5.x86_64 keyutils-libs-1.4-4.el6.x86_64 krb5-libs-1.9-33.el6_3.3.x86_64 libcom_err-1.41.12-12.el6.x86_64 libgcc-4.4.6-4.el6.x86_64 libselinux-2.0.94-5.3.el6.x86_64 libsepol-2.0.41-4.el6.x86_64 libudev-147-2.42.el6.x86_64 libxml2-2.7.6-8.el6_3.3.x86_64 lvm2-libs-2.02.95-10.el6_3.2.x86_64 openssl-1.0.0-25.el6_3.1.x86_64 zlib-1.2.3-27.el6.x86_64
(gdb) bt
#0  0x00007f21e88be022 in glusterd_op_ac_send_lock (event=0x7f21d819eff0, ctx=0x0)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:2144
#1  0x00007f21e88c5d8b in glusterd_op_sm () at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:5385
#2  0x00007f21e890ba01 in glusterd_handle_cli_delete_volume (req=0x7f21e74e002c)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-volume-ops.c:427
#3  0x00007f21ecc9c324 in synctask_wrap (old_task=0x220fda0) at /var/lib/jenkins/jobs/smoke/workspace/libglusterfs/src/syncop.c:129
#4  0x00007f21ebf0bb80 in ?? () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()
(gdb) f 0
#0  0x00007f21e88be022 in glusterd_op_ac_send_lock (event=0x7f21d819eff0, ctx=0x0)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:2144
2144	                if (!peerinfo->connected || !peerinfo->mgmt)
(gdb) p peerinfo
$1 = (glusterd_peerinfo_t *) 0xffffffffffffff90
(gdb) info thr
  6 Thread 0x7f21ed0e7700 (LWP 11661)  0x00007f21ebfb0713 in epoll_wait () from /lib64/libc.so.6
  5 Thread 0x7f21e9f51700 (LWP 11663)  0x00007f21ec6007bb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
  4 Thread 0x7f21e52d5700 (LWP 11728)  0x00007f21ec603d2d in nanosleep () from /lib64/libpthread.so.0
  3 Thread 0x7f21ea952700 (LWP 11662)  0x00007f21ec6042a5 in sigwait () from /lib64/libpthread.so.0
  2 Thread 0x7f21e60f3700 (LWP 11681)  0x00007f21ec60043c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
* 1 Thread 0x7f21e9550700 (LWP 11664)  0x00007f21e88be022 in glusterd_op_ac_send_lock (event=0x7f21d819eff0, ctx=0x0)
    at /var/lib/jenkins/jobs/smoke/workspace/xlators/mgmt/glusterd/src/glusterd-op-sm.c:2144


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Often

Steps to Reproduce:
1. Run regression test for bug 879490
2. glusterd crash is observed

  
Actual results:


Expected results:


Additional info:
Comment 1 Amar Tumballi 2013-01-08 07:08:09 EST

*** This bug has been marked as a duplicate of bug 889382 ***

Note You need to log in before you can comment on or make changes to this bug.