Bug 889551 - Remove spice live migration warning for Native USB redirection in cluster level 3.2
Remove spice live migration warning for Native USB redirection in cluster lev...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
All Linux
high Severity high
: ---
: 3.2.0
Assigned To: Roy Golan
Jiri Belka
virt
: Patch
: 884703 (view as bug list)
Depends On: 894396
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-21 12:20 EST by Raul Cheleguini
Modified: 2014-02-24 18:48 EST (History)
12 users (show)

See Also:
Fixed In Version: sf7
Doc Type: Enhancement
Doc Text:
Live migration is now supported when using Native USB redirection in cluster level 3.2
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10925 None None None Never

  None (edit)
Description Raul Cheleguini 2012-12-21 12:20:14 EST
Description of problem:

The following message is displayed by RHEV Manager when administrator choose "Native" for USB Support at "Console" tab in virtual machine properties console:

"Migration is NOT currently supported using SPICE Native USB redirection"

The warning above it is ambiguous (And its translated versions) and can lead to misinterpretations. There is a considerable number of "migrations" in RHEV context (Migration between versions, migrate a vm between Storage Domains, live migrations, etc).

So, I believe the warnings like this should be better stated/self-explanatory, for instance:

"VM live migration between hosts is NOT currently supported using SPICE Native USB redirection, please try to use Legacy mode"



Version-Release number of selected component (if applicable):

RHEV Manager 3.1.0-32.el6ev

How reproducible:

Create a VM > Edit properties > Console > USB Support > Native


Steps to Reproduce:

Create a VM > Edit properties > Console > USB Support > Native
  
Actual results:

"Migration is NOT currently supported using SPICE Native USB redirection" is displayed and it is ambiguous.

Expected results:

More specific warning, for instance:

"VM live migration between hosts is NOT currently supported using SPICE Native USB redirection"
Comment 1 Amador Pahim 2012-12-26 15:57:01 EST
Proposed patch:
http://gerrit.ovirt.org/10406
Comment 4 Amador Pahim 2013-01-04 06:39:34 EST
What about this message?
"Using SPICE Native USB redirection, VM live migration between hosts will NOT be supported before RHEL 6.4."
Comment 7 Michal Skrivanek 2013-01-13 11:29:14 EST
*** Bug 884703 has been marked as a duplicate of this bug. ***
Comment 8 Jiri Belka 2013-02-14 09:26:50 EST
ok, sf7.
Comment 9 Itamar Heim 2013-06-11 04:35:42 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 04:35:49 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:35:54 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:44:27 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.