Bug 889724 - No option to select a _partition_ (vs a device) to install grub on
No option to select a _partition_ (vs a device) to install grub on
Status: CLOSED DUPLICATE of bug 872826
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-12-22 18:35 EST by François Cami
Modified: 2012-12-23 23:39 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-23 11:12:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description François Cami 2012-12-22 18:35:39 EST
Description of problem:
Unless I am mistaken, Anaconda won't let me select sda3 as the partition to install the bootloader on, only sda. This impacts multiboot.

I have 7 partitions on my HDD:
* sda1 => /boot for OS #1
* sda2 => /boot for OS #2
* sda3 => /boot for OS #3
* sda4 => extended
* sda5 => PV for OS #1
* sda6 => PV for OS #2
* sda7 => PV for OS #3
OS #1's grub chainloads to the other bootloaders, of course.

RHEL5, RHEL6, and Fedora up to 17 included let me select a partition instead of a device to install the GRUB bootloader on. With F18, I could not find the option to do so, there is only a graphical drive list, with a bootable flag. 

Version-Release number of selected component (if applicable):
The one in Smoke12 at http://dl.fedoraproject.org/pub/alt/qa/20121221_f18-smoke12/ .

How reproducible:

Steps to Reproduce:
1. Boot installer
2. Go to partition selection, click on drives, etc
Actual results:
The bootable flags affects only the whole drive, leading presumably to a bootloaer installed on /dev/sda.

Expected results:
Being able to select /dev/sdaX.
Comment 1 François Cami 2012-12-22 18:41:29 EST
I should add that all the OSes installed on that drive are part of the Red Hat family - RHEL, and Fedora.
Comment 2 Paul Franklin (RHlists) 2012-12-23 10:50:33 EST
I am not a Fedora "regular" (and do not speak for any part
of the Fedora project) but I suggest that if you do a Google
search you will find many related bug reports, for instance
bub 872826 and bug 867469 and bug 886502 and bug 885240 .
Comment 3 François Cami 2012-12-23 11:12:00 EST
Thank you Paul, I am going to close my bug as a duplicate of bug 872826 .

For the record, installing Fedora 17 first (using the Minimal profile for instance), then using fedup-cli to upgrade to Fedora 18 works as expected.
Comment 4 François Cami 2012-12-23 11:12:21 EST

*** This bug has been marked as a duplicate of bug 872826 ***

Note You need to log in before you can comment on or make changes to this bug.