Bug 889908 - QA:Testcase Anaconda User Interface serial console - Partial Failure
QA:Testcase Anaconda User Interface serial console - Partial Failure
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks: bonding/Bug/interface/multiple
  Show dependency treegraph
 
Reported: 2012-12-23 20:39 EST by Robert Lightfoot
Modified: 2013-01-02 13:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 13:48:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemctl status serial-getty@ttyS0.service (5.29 KB, image/png)
2012-12-23 20:39 EST, Robert Lightfoot
no flags Details
securetty (3.53 KB, image/png)
2012-12-23 20:40 EST, Robert Lightfoot
no flags Details

  None (edit)
Description Robert Lightfoot 2012-12-23 20:39:27 EST
Created attachment 668251 [details]
systemctl status serial-getty@ttyS0.service

Description of problem:
Following the Test Case Instructions Expected Results 4,5 & 6 are not achieved.
4. The installed system displays GRUB boot menu to the serial console.
5. The installed system prints boot messages to the serial console.
6. The installed system present a working login prompt to the serial console. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Follow the test case instrucitons
  
Actual results:
Following the Test Case Instructions Expected Results 4,5 & 6 are not achieved.

Expected results:
Test Case PASS

Additional info:
A working system is produced, but anaconda failed to add console=ttyS0 to any entry in /boot/grub2/grub.cfg.  For this reason there is no console output.  I manually added the console=ttyS0 and rebooted. Expected result 4 still was not achieved, but 5 & 6 were met.
Comment 1 Robert Lightfoot 2012-12-23 20:40:17 EST
Created attachment 668252 [details]
securetty
Comment 2 Chris Lumens 2013-01-02 10:53:26 EST
Please attach /tmp/anaconda.log, /tmp/syslog, and /tmp/program.log to this bug report.  Thanks.
Comment 3 Adam Williamson 2013-01-02 13:36:10 EST
Discussed at 2013-01-02 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2013-01-02/f18final-blocker-review-8.2013-01-02-17.03.log.txt . kparal could not reproduce this bug in a couple of re-tests, so for now it's rejected as a blocker. Bob will re-test with TC3 and smoke12 and make sure he passes the parameter correctly, and if necessary we can re-evaluate from there.
Comment 4 Robert Lightfoot 2013-01-02 13:48:49 EST
Closed works for me now with TC3 -- looks like I forgot and used only console=ttyS0 first time and console=ttyS0 serial the working time.

Note You need to log in before you can comment on or make changes to this bug.