Bug 499109 - (bonding, Bug, interface, multiple) Bug kernel bonding multiple interface
Bug kernel bonding multiple interface
Status: CLOSED DUPLICATE of bug 498024
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Andy Gospodarek
Red Hat Kernel QE team
:
Depends On: 569762 580028 734731 885912 886314 889896 889908 999283 1080119 1084603 1138643
Blocks: 1168026 1302182 1306119 507584 512276 554285 573940 584785 624265 665738 735030 947391 1018916 1079590
  Show dependency treegraph
 
Reported: 2009-05-05 05:02 EDT by vincent.leriche
Modified: 2016-04-14 11:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 11:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description vincent.leriche 2009-05-05 05:02:49 EDT
Description of problem:
Activate multiple bond interface and i have bug kernel :

kernel: BUG: soft lockup - CPU#0 stuck for 10s! [bond2:2740]
kernel: CPU 0:
kernel: Modules linked in: mptctl mptbase sg ipmi_devintf ipmi_si ipmi_ms
ghandler autofs4 nfs lockd fscache nfs_acl rfcomm l2cap bluetooth sunrpc bonding dm_mirror dm_multipath d
m_mod video sbs backlight i2c_ec i2c_core button battery asus_acpi acpi_memhotplug ac parport_pc lp parpo
rt serio_raw pcspkr bnx2 e1000e shpchp i5000_edac edac_mc ata_piix libata cciss sd_mod scsi_mod ext3 jbd 
uhci_hcd ohci_hcd ehci_hcd
kernel: Pid: 2740, comm: bond2 Not tainted 2.6.18-92.el5 #1
kernel: RIP: 0010:[<ffffffff80064b7b>]  [<ffffffff80064b7b>] .text.lock.s
pinlock+0x29/0x30
kernel: RSP: 0018:ffff81022845bd20  EFLAGS: 00000286
kernel: RAX: ffff81022845bfd8 RBX: ffff81022ea78000 RCX: ffff81022845bd80
kernel: RDX: 0000000000008947 RSI: ffff81022845bd70 RDI: ffff81022ea78714
kernel: RBP: ffffffff80142f55 R08: ffff81022845a000 R09: 000000000000003c
kernel: R10: ffff81022fe5c038 R11: ffff81022f601400 R12: 0000000000000003
kernel: R13: ffff810228ba0500 R14: ffff810228ba0500 R15: 00000000656c6f73
kernel: FS:  0000000000000000(0000) GS:ffffffff8039e000(0000) knlGS:00000
00000000000
kernel: CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
kernel: CR2: 00002acbe74eb000 CR3: 00000002243ae000 CR4: 00000000000006e0
kernel: 
kernel: Call Trace:
kernel: [<ffffffff88166bba>] :bnx2:bnx2_ioctl+0x69/0xff
kernel: [<ffffffff88289ed5>] :bonding:bond_check_dev_link+0x7e/0x1b9
kernel: [<ffffffff80062efb>] thread_return+0x0/0xdf
kernel: [<ffffffff8828b5e0>] :bonding:__bond_mii_monitor+0x88/0x444
kernel: [<ffffffff8828c9c2>] :bonding:bond_mii_monitor+0x0/0x8c
kernel: [<ffffffff8828c9ef>] :bonding:bond_mii_monitor+0x2d/0x8c
kernel: [<ffffffff8004cea9>] run_workqueue+0x94/0xe4
kernel: [<ffffffff800497be>] worker_thread+0x0/0x122
kernel: [<ffffffff8009dbca>] keventd_create_kthread+0x0/0xc4
kernel: [<ffffffff800498ae>] worker_thread+0xf0/0x122
kernel: [<ffffffff8008ac03>] default_wake_function+0x0/0xe
kernel: [<ffffffff8009dbca>] keventd_create_kthread+0x0/0xc4
kernel: [<ffffffff8009dbca>] keventd_create_kthread+0x0/0xc4
kernel: [<ffffffff8003253d>] kthread+0xfe/0x132
kernel: [<ffffffff8005dfb1>] child_rip+0xa/0x11
kernel: [<ffffffff8009dbca>] keventd_create_kthread+0x0/0xc4
kernel: [<ffffffff8003243f>] kthread+0x0/0x132
kernel: [<ffffffff8005dfa7>] child_rip+0x0/0x11

This problem occurs after a little time (1 day) after the reboot.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

cat /etc/modprobe.conf 
alias bond0 bonding
options bond0 use_carrier=0 mode=1 miimon=100
options bonding max_bonds=3
alias bond1 bonding
options bond1 use_carrier=0 mode=1 miimon=100
options bonding max_bonds=3
alias bond2 bonding
options bond2 use_carrier=0 mode=1 miimon=100
options bonding max_bonds=3
alias eth0 bnx2
alias eth1 bnx2
alias eth2 e1000e
alias eth3 e1000e
alias eth4 e1000e
alias eth5 e1000e
alias scsi_hostadapter cciss
alias scsi_hostadapter1 ata_piix
alias net-pf-10 off
alias ipv6 off
[root@tpnocp14v ~]# 

And file ifcfg-bondX and ifcfg-ethX :

cat ifcfg-bond0
ONBOOT=yes
BOOTPROTO=static
TYPE=bonding
DEVICE=bond0
IPADDR=10.18.124.33
BROADCAST=10.18.125.255
NETMASK=255.255.254.0
ETHTOOL_OPTS="autoneg on"

cat ifcfg-eth0
ONBOOT=yes
BOOTPROTO=none
DEVICE=eth0
MASTER=bond0
HWADDR=00:23:7D:21:ED:08
SLAVE=yes
USERCTL=no
ETHTOOL_OPTS="autoneg on"
Comment 1 Andy Gospodarek 2009-05-12 11:29:52 EDT
This was also reported in bug 498024, so I am going to close this as a duplicate of that bug.  Please post all comments there.

In the meantime, have you been able to try the latest 5.3 kernels or my test kernels here:

http://people.redhat.com/agospoda/#rhel5

Thanks!

*** This bug has been marked as a duplicate of bug 498024 ***
Comment 2 abdussalamk 2009-10-10 09:35:35 EDT
Dear Sirs, Hi,

I tried to configure bonding on Redhat Enterprise Linux 5.3 on a Dell PowerEdge 2950 server using Broadcom NICs BCM 5708 bnx2; 

please check the follwoing are the configuration details; 

/etc/sysconfig/netword-scripts/ifcfg-bond0
DEVICE=bond0
USERCTL=no
ONBOOT=yes
BROADCAST=10.x.y.255
NETWORK=10.x.y.0
NETMASK=255.255.255.0
GATEWAY=10.x.y.1
IPADDR=10.x.y.65

/etc/sysconfig/netword-scripts/ifcfg-eth0
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

/etc/sysconfig/netword-scripts/ifcfg-eth1
DEVICE=eth1
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none


/etc/modprobe.conf
alias eth0 bnx2
alias eth1 bnx2
alias scsi_hostadapter megaraid_sas
alias scsi_hostadapter1 ata_piix
alias scsi_hostadapter2 qla2xxx
alias peth0 bnx2

alias bond0 bonding
options bonding miimon=100 mode=0


after the configuration, when I restart the network service, the following Messages are displays

# service network restart
Shutting down interface bond0:  bonding: bond0: Warning: the permanent HWaddr of eth0 - 00:24:E8:5E:8F:F3 - is still in use by bond0. Set the HWaddr of eth0 to
a different address to avoid conflicts.
                                                           [  OK  ]
Shutting down interface eth0:  bonding: bond0: Unable to update slaves because interface is down.
                                                           [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Disabling IPv4 packet forwarding:  net.ipv4.ip_forward = 0
                                                           [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface bond0:  bonding: bond0: Warning: failed to get speed and duplex from eth0, assumed to be 100Mb/sec and Full.
                                                           [  OK  ]
please advice me how can i solve this issue; 

your valuable Suggestions is highly appriciable on this .

Best Regards,
Salam
Comment 3 abdussalamk 2009-10-11 02:55:12 EDT
Dear Sirs, Hi,

I tried to configure bonding on Redhat Enterprise Linux 5.3 on a Dell PowerEdge 2950 server using Broadcom NICs BCM 5708 bnx2; 

please check the follwoing are the configuration details; 

/etc/sysconfig/netword-scripts/ifcfg-bond0
DEVICE=bond0
USERCTL=no
ONBOOT=yes
BROADCAST=10.x.y.255
NETWORK=10.x.y.0
NETMASK=255.255.255.0
GATEWAY=10.x.y.1
IPADDR=10.x.y.65

/etc/sysconfig/netword-scripts/ifcfg-eth0
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

/etc/sysconfig/netword-scripts/ifcfg-eth1
DEVICE=eth1
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none


/etc/modprobe.conf
alias eth0 bnx2
alias eth1 bnx2
alias scsi_hostadapter megaraid_sas
alias scsi_hostadapter1 ata_piix
alias scsi_hostadapter2 qla2xxx
alias peth0 bnx2

alias bond0 bonding
options bonding miimon=100 mode=0


after the configuration, when I restart the network service, the following Messages are displays

# service network restart
Shutting down interface bond0:  bonding: bond0: Warning: the permanent HWaddr of eth0 - 00:24:E8:5E:8F:F3 - is still in use by bond0. Set the HWaddr of eth0 to
a different address to avoid conflicts.
                                                           [  OK  ]
Shutting down interface eth0:  bonding: bond0: Unable to update slaves because interface is down.
                                                           [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Disabling IPv4 packet forwarding:  net.ipv4.ip_forward = 0
                                                           [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface bond0:  bonding: bond0: Warning: failed to get speed and duplex from eth0, assumed to be 100Mb/sec and Full.
                                                           [  OK  ]
please advice me how can i solve this issue; 

your valuable Suggestions is highly appriciable on this .

Best Regards,
Salam
Comment 4 Andy Gospodarek 2009-10-12 10:30:45 EDT
(In reply to comment #3)
> Dear Sirs, Hi,
> 
> I tried to configure bonding on Redhat Enterprise Linux 5.3 on a Dell PowerEdge
> 2950 server using Broadcom NICs BCM 5708 bnx2; 
> 
> please check the follwoing are the configuration details; 
> 
> /etc/sysconfig/netword-scripts/ifcfg-bond0
> DEVICE=bond0
> USERCTL=no
> ONBOOT=yes
> BROADCAST=10.x.y.255
> NETWORK=10.x.y.0
> NETMASK=255.255.255.0
> GATEWAY=10.x.y.1
> IPADDR=10.x.y.65
> 
> /etc/sysconfig/netword-scripts/ifcfg-eth0
> DEVICE=eth0
> USERCTL=no
> ONBOOT=yes
> MASTER=bond0
> SLAVE=yes
> BOOTPROTO=none
> 
> /etc/sysconfig/netword-scripts/ifcfg-eth1
> DEVICE=eth1
> USERCTL=no
> ONBOOT=yes
> MASTER=bond0
> SLAVE=yes
> BOOTPROTO=none
> 
> 
> /etc/modprobe.conf
> alias eth0 bnx2
> alias eth1 bnx2
> alias scsi_hostadapter megaraid_sas
> alias scsi_hostadapter1 ata_piix
> alias scsi_hostadapter2 qla2xxx
> alias peth0 bnx2
> 
> alias bond0 bonding
> options bonding miimon=100 mode=0
>

Please consider removing the line 'options bonding miimon=100 mode=0' from modprobe.conf and place this line in ifcfg-bond0

BONDING_OPTS="miimon=100 mode=0"

RHEL5 and later support setting the bonding options in the ifcfg-bondX file, not in modprobe.conf.

> 
> after the configuration, when I restart the network service, the following
> Messages are displays
> 
> # service network restart
> Shutting down interface bond0:  bonding: bond0: Warning: the permanent HWaddr
> of eth0 - 00:24:E8:5E:8F:F3 - is still in use by bond0. Set the HWaddr of eth0
> to
> a different address to avoid conflicts.

This message is not important unless you remove eth0 from bond0, but continue to use both.  You can ignore it when it appears when restarting the network or if you perform 'ifdown bond0'

> Bringing up interface bond0:  bonding: bond0: Warning: failed to get speed and
> duplex from eth0, assumed to be 100Mb/sec and Full.
>                                                            [  OK  ]

This message indicates that the link-speed detected does not match the limits of 10/100/1000Mbit that the bonding driver expects or the link is not up.  What speed is reported by the command 'ethtool eth0'?

If something other than 10, 100, or 1000Mbit is reported or the link is not UP this message is expected and can be ignored.

Note You need to log in before you can comment on or make changes to this bug.