Bug 89008 - Accessing Published Multi-Part Article causes CCM Error
Accessing Published Multi-Part Article causes CCM Error
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Ross
Jon Orris
:
: 89304 (view as bug list)
Depends On:
Blocks: 87722
  Show dependency treegraph
 
Reported: 2003-04-16 10:45 EDT by Jon Orris
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 18:31:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-04-16 10:45:25 EDT
Description of problem:
@29857/RHDB
TestCase: MultiArticleSmoke

Create a multi-part article & publish it. Go to the public site & click the link
for the article. 

Title is Multi Part Article Test. URL fragment is multi-test. The index page
link is ccm/articles/multi-test.en?g11n.enc=ISO-8859-1

Marking blocked for Beta 1, as this may be signifigant for the demo server. 

-*-*-*- ACS Error Report Code:
ccm-installer.boston.redhat.com:8080:4ec2f1f:f496a50aef -*-*-*-
-*-*-*- Message:  -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
accept-encoding: gzip,deflate,compress;q=0.9
accept-language: en-us,en;q=0.5
connection: keep-alive
cookie: JSESSIONID=DFEBED0D85E8AE8731D5506C49B89ACE;
ad_user_login=3008!1145106795837!6M66Tr0OTbTXkzTriznV9g==
host: ccm-installer.boston.redhat.com:8080
keep-alive: 300
referer:
http://ccm-installer.boston.redhat.com:8080/ccm/articles/index/?g11n.enc=ISO-8859-1
user-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: DFEBED0D85E8AE8731D5506C49B89ACE (expires: -1)
ad_user_login: 3008!1145106795837!6M66Tr0OTbTXkzTriznV9g== (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
java.lang.IllegalStateException: 
	at com.arsdigita.util.Assert.assertTrue(Assert.java(Compiled Code))
	at com.arsdigita.util.Assert.assertTrue(Assert.java(Compiled Code))
	at com.arsdigita.cms.Folder.getItem(Folder.java:223)
	at
com.arsdigita.cms.dispatcher.MultilingualItemResolver.getItemFromLiveURL(MultilingualItemResolver.java:852)
	at
com.arsdigita.cms.dispatcher.MultilingualItemResolver.getItem(MultilingualItemResolver.java:141)
	at com.arsdigita.cms.ContentSectionServlet.getItem(ContentSectionServlet.java:205)
	at com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:91)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doGet(BaseServlet.java:205)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:683)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:431)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:355)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:247)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:243)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:190)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2347)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:180)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:170)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:170)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:468)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:174)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:1027)
	at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1125)
	at java.lang.Thread.run(Thread.java:512)


-*-*-*- Section: Servlet attributes -*-*-*-
com.arsdigita.dispatcher.RequestContext:
com.arsdigita.sitenode.SiteNodeRequestContext@fb56f2f
com.arsdigita.dispatcher.RequestValue:
{com.arsdigita.dispatcher.RequestValue@23a2f0d=null}
com.arsdigita.web.BaseApplicationServlet.application_id: 14
com.arsdigita.web.BaseDispatcher.dispatched: true
com.arsdigita.web.BaseServlet.request_url:
/ccm/articles/multi-test.en?g11n.enc=ISO-8859-1
guruErrorReport: 
-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code:
ccm-installer.boston.redhat.com:8080:4ec2f1f:f496a508fd -*-*-*-
-*-*-*- Message:  -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
accept-encoding: gzip,deflate,compress;q=0.9
accept-language: en-us,en;q=0.5
connection: keep-alive
cookie: JSESSIONID=DFEBED0D85E8AE8731D5506C49B89ACE;
ad_user_login=3008!1145106795837!6M66Tr0OTbTXkzTriznV9g==
host: ccm-installer.boston.redhat.com:8080
keep-alive: 300
referer:
http://ccm-installer.boston.redhat.com:8080/ccm/articles/index/?g11n.enc=ISO-8859-1
user-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: DFEBED0D85E8AE8731D5506C49B89ACE (expires: -1)
ad_user_login: 3008!1145106795837!6M66Tr0OTbTXkzTriznV9g== (expires: -1)
Comment 1 Justin Ross 2003-04-16 17:56:23 EDT
I wasn't able to reproduce this.  I'm on postgres here too.  I tried creating
one with a hyphen name, like you did, and I tried creating an mparticle in a
subfolder.
Comment 2 Jon Orris 2003-04-22 11:22:38 EDT
*** Bug 89304 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.