This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 890331 - vdsm: engine is sending remove volume twice to vdsm when removing a vm (remove VM will fail and cause an inconsistent image state)
vdsm: engine is sending remove volume twice to vdsm when removing a vm (remov...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Eduardo Warszawski
Dafna Ron
storage
:
Depends On:
Blocks: 890826
  Show dependency treegraph
 
Reported: 2012-12-26 07:53 EST by Dafna Ron
Modified: 2016-02-10 15:25 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 16:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs (1.18 MB, application/x-gzip)
2012-12-26 07:53 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-12-26 07:53:30 EST
Created attachment 669218 [details]
logs

Description of problem:

RemoveVMVDSCommand sends delete volume 
RemoveAllVmImagesCommand will send deleteImage which also has delete volume. 


Version-Release number of selected component (if applicable):

si25.2

How reproducible:

100%

Steps to Reproduce:
1. delete a vm 
2.
3.
  
Actual results:

engine sends RemoveVm and DeleteImage - both commands will remove volume in the vdsm 

Expected results:

there is no no need to send delete volume twice

Additional info:
Comment 1 Ayal Baron 2012-12-27 10:02:46 EST
I could not find
removeVM in vdsm does not delete the image nor the volume.
In the log I couldn't find any deleteVolume operations called by the engine (nor any call in engine that would support this claim).
Comment 5 Daniel Paikov 2013-03-11 12:24:23 EDT
Unable to reproduce on latest 3.2.

Note You need to log in before you can comment on or make changes to this bug.