Bug 890826 - engine: can't remove a vm with "image does not exist" after image was previously removed in storage but not from db
engine: can't remove a vm with "image does not exist" after image was previou...
Status: CLOSED DUPLICATE of bug 885489
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.1.1
Assigned To: Ayal Baron
Dafna Ron
storage
: Regression, TestBlocker, TestOnly, Tracking
Depends On: 864530 890331
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-30 09:03 EST by Dafna Ron
Modified: 2013-02-21 11:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-31 07:27:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-12-30 09:03:19 EST
Description of problem:

we have several cases in which we cannot remove a vm with error "Image does not exist" 
although the image was removed from the storage it was not removed from the DB for different reasons. 
when trying to remove the image we cannot since engine sends the command to vdsm wich returns with an error -> backends fails the command. 

Please note that we also cannot force remove a vm from api/cli (this option does not work). 

since we had several cases like in the last day on our setups we decided to open a tracker bug.
Comment 2 Ayal Baron 2012-12-31 07:27:47 EST

*** This bug has been marked as a duplicate of bug 885489 ***

Note You need to log in before you can comment on or make changes to this bug.