Bug 89098 - Tk/Tcl handling of UTF-8 appears broken
Summary: Tk/Tcl handling of UTF-8 appears broken
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 89110
TreeView+ depends on / blocked
 
Reported: 2003-04-17 16:47 UTC by Michael Fulbright
Modified: 2007-04-18 16:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 07:25:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample program to trigger utf-8 issue (405 bytes, text/plain)
2003-04-17 16:48 UTC, Michael Fulbright
no flags Details
Tkinter equivalent? to utf-8.wish (364 bytes, application/octet-stream)
2003-07-04 21:51 UTC, Jens Petersen
no flags Details

Description Michael Fulbright 2003-04-17 16:47:40 UTC
The attached program runs fine on a Red Hat Linux 8 system, but displays a
mixture of characters and square boxes on Shrike.

Comment 1 Michael Fulbright 2003-04-17 16:48:25 UTC
Created attachment 91178 [details]
Sample program to trigger utf-8 issue

Comment 2 Jens Petersen 2003-06-18 02:39:26 UTC
Reproduced.  Wonder if this is related to the move to ucs4 for python.

Comment 3 Jens Petersen 2003-06-18 02:50:49 UTC
Indeed it is.  Removing tcltk-8.3.5-ucs4-for-py.patch, it displays just fine.

Misa, do you have any utf-8 test-cases for tkinter?

Comment 4 Jens Petersen 2003-07-04 21:38:50 UTC
In tcltk-8.3.5-90 I have disabled the ucs4 patch for now, since it seems
to be breaking utf-8 support.  But this is probably not the final
solution.  At least now "utf-8.wish" displays ok again, though the
equivalent(?) Tkinter python script does not.

Comment 5 Jens Petersen 2003-07-04 21:51:27 UTC
Created attachment 92758 [details]
Tkinter equivalent? to utf-8.wish

Actually this script doesn't seem to display correctly with
or without the patch.  What is the right way to do this with
python and Tkinter?

Comment 6 Mihai Ibanescu 2004-04-16 21:45:13 UTC
try:

... text=u'...'

instead of

... text='...'

Works on my FC2 box


Note You need to log in before you can comment on or make changes to this bug.