This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 891053 - 3.1.z Error deleting VM disk
3.1.z Error deleting VM disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: 6.3
Assigned To: Yeela Kaplan
Haim
storage
: ZStream
: 891054 (view as bug list)
Depends On: 885489 891054
Blocks: 891052
  Show dependency treegraph
 
Reported: 2013-01-01 07:43 EST by Ayal Baron
Modified: 2016-02-02 17:39 EST (History)
19 users (show)

See Also:
Fixed In Version: vdsm-4.9.6-44.3
Doc Type: Bug Fix
Doc Text:
A typographical mistake in the rmDCImgDir function of blockSD.py meant that when an OSError exception was encountered it was not logged correctly. The mistake has been corrected and the function now logs errors correctly.
Story Points: ---
Clone Of: 885489
Environment:
Last Closed: 2013-01-15 09:52:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Ayal Baron 2013-01-01 07:50:57 EST
*** Bug 891054 has been marked as a duplicate of this bug. ***
Comment 5 Haim 2013-01-06 07:22:18 EST
verified on vdsm4.9.6-44.3 installed on QE production environment.
managed to delete a VM (disk) where the image was missing, instead of exception I got valid error message of:

Thread-491::ERROR::2013-01-06 14:09:30,662::dispatcher::66::Storage.Dispatcher.Protect::(run) {'status': {'message': "Image does not exist in domain: 'image=0def7577-eec8-48e0-
8100-1e492752fc47, domain=d5d0dfe6-c2b9-429e-96c2-c1cd247ac828'", 'code': 268}}
Comment 7 errata-xmlrpc 2013-01-15 09:52:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0159.html

Note You need to log in before you can comment on or make changes to this bug.