Bug 89114 - python quota library does not compile in recent versions of libuser
python quota library does not compile in recent versions of libuser
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: libuser (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
: 89116 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 15:19 EDT by Dana Canfield
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version: 0.51.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 18:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dana Canfield 2003-04-17 15:19:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
In RH9 (and 8 as well I believe), the libuserquota python module does not
compile properly.  I know very little about C, but my suspicion is that the
version of the quota package changed and broke the python module.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. edit SPEC file to include --enable-quotas
2. rpmbuild --rebuild 
3. Check that libuserquota was not built.

Attempting to compile manually doesn't work either.   

Actual Results:  Library for python was not build.  Hacking the makefiles by
hand caused the build of the quota library to still fail.

Expected Results:  Successful compilation

Additional info:
Comment 1 Brent Fox 2003-09-16 16:24:31 EDT
*** Bug 89116 has been marked as a duplicate of this bug. ***
Comment 2 Miloslav Trmač 2004-09-02 12:48:30 EDT
First, the argument is --enable-quota.

Other than that, the configure mechanism didn't work at all
and there were several compilation errors that will be fixed
in the next libuser release.

As you can see, the quota code has probably never been used
in practice, so its usage in production is dicouraged at this time.
Comment 3 Miloslav Trmač 2004-09-02 18:21:16 EDT
Should be fixed in libuser-0.51.10-1, when it hits rawhide.

Note You need to log in before you can comment on or make changes to this bug.