Bug 89117 - Adding bzip2 support to pax
Adding bzip2 support to pax
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pax (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 15:37 EDT by Matt Thompson
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 05:22:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Thompson 2003-04-17 15:37:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
I'm requesting support for bzip2 in pax as I use pax quite a bit and have many
tarballs using bz2.  I am currently using a version from here (pax-3.1):

http://www.gtlib.cc.gatech.edu/pub/suse/people/kukuk/pax/

which I patched following this:

http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=20495

The patch obviously isn't one-to-one, and but it's easy enough to add a

#define BZIP2_CMD "bzip2"

and then add in the "j" flags to the getopt and "case 'j':" bits in the
pax_options() and tar_options() in options.c, and copy the -z bits in pax.1 to a
-j entry.

Also, there probably should be code amended to pax.c so that -a can't be used
with gzip/bzip2 (it will error since either -z or -j calls gzip_program).

I can't provide a diff patch as I'm not exactly sure if pax-3.1 is very
different from the pax-3.0-6 currently used in Red Hat 9, and if you'd want to
upgrade to 3.1.  If needed I can attach the options.c and pax.1 I made from pax-3.1.

One final oddity is that using pax -wjf trial.pax trial/ will work, but a
subsequent ls -ltr doesn't seem to show the file size.  But, the file is there!
 Could be a problem using a SuSe tarball on Red Hat?

Version-Release number of selected component (if applicable):
pax-3.0-6

How reproducible:
Always

Steps to Reproduce:
1.  Try running "pax -jf pax-3.1.tar.bz2"
2.  Error thrown since no bzip2 support in pax.
3.  Same for pax -rjf, pax -wjf
    

Actual Results:  Throws error since pax doesn't support bzip2.

Expected Results:  Should get a listing of files, or extract/write a bzip2'd
archive.

Additional info:
Comment 1 Peter Vrabec 2005-11-09 05:22:51 EST
It is not accepted by upstream.

Note You need to log in before you can comment on or make changes to this bug.