Bug 891281 - sssd is not serving large automount maps reliably
Summary: sssd is not serving large automount maps reliably
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-02 12:50 UTC by Ondrej Valousek
Modified: 2014-06-18 03:59 UTC (History)
4 users (show)

Fixed In Version: sssd-1.10.0-1.el7.alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 13:13:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
log file (189.09 KB, text/x-log)
2013-01-11 11:15 UTC, Ondrej Valousek
no flags Details

Description Ondrej Valousek 2013-01-02 12:50:20 UTC
Description of problem:
When using sssd to serve maps for automounter it sometimes happen that certain maps are not 'seen'. I observe this behavior with large maps (~100 keys):
[root@logind yum.repos.d]# automount -m | grep 'orlaj'
[root@logind yum.repos.d]# automount -m | grep 'orlaj'
[root@logind yum.repos.d]# automount -m | grep 'orlaj'
  orlaj | belfast:/vol/users/users/&

But the requested key is in the cache:

[root@logind yum.repos.d]# ldb3search -H /var/lib/sss/db/cache_default.ldb -b cn=autofsmaps,cn=custom,cn=default,cn=sysdb | grep orl
no symbol `init_samba_module' found in /usr/lib64/ldb/memberof.so: /usr/lib64/ldb/memberof.so: undefined symbol: init_samba_module
WARNING: Module [memberof] not found
asq: Unable to register control with rootdse!
dn: name=orlajbelfast:/vol/users/users/&,name=auto.home,cn=autofsmaps,cn=custom,cn=default,cn=sysdb
automountKey: orlaj
name: orlajbelfast:/vol/users/users/&
distinguishedName: name=orlajbelfast:/vol/users/users/&,name=auto.home,cn=auto

Version-Release number of selected component (if applicable):
sssd-1.9.2-6.upstream_1_9_3.el6_3.x86_64

How reproducible:
run 'automount -m' command a couple of times and look for missing keys.
Quite easily reproducible.

Steps to Reproduce:
1. configure sssd&autofs to serve maps for automounter
2. run 'automount -m' a couple of times
3.
  
Actual results:
output of the command 'automount -m' is not consistent

Expected results:
'automount -m' should always return the same result

Comment 2 Jakub Hrozek 2013-01-03 10:06:21 UTC
Pavel will try to reproduce locally.

Comment 3 Dmitri Pal 2013-01-03 14:36:06 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1739

Comment 4 Pavel Březina 2013-01-07 10:48:41 UTC
Hi,
I was unable to reproduce it so far. Can you provider logs please? Thank you.

Comment 5 Ondrej Valousek 2013-01-07 12:42:45 UTC
Logs provided privately by mail.

Comment 6 Pavel Březina 2013-01-11 09:22:42 UTC
Hi,
unfortunately, the domain log didn't contain anything interesting. Number of returned values is consistent here and everything seems to work as expected. It looks more like a responder problem. Can you provide also sssd_autofs.log please? Thank you.

Comment 7 Ondrej Valousek 2013-01-11 10:02:48 UTC
Hello,
File sssd_autofs.log is empty.

Comment 8 Pavel Březina 2013-01-11 10:48:38 UTC
Would it be possible for you to enable debugging for autofs service?

[autofs]
debug_level = level

The best level for us would be 0xfff0.

Comment 9 Ondrej Valousek 2013-01-11 11:15:32 UTC
Created attachment 676815 [details]
log file

Attached the log file as requested. Nothing really interesting in there, but I was still able to replicate the issue.

Ondrej

Comment 10 Jakub Hrozek 2013-03-26 18:14:24 UTC
Fixed upstream.

Comment 11 Jakub Hrozek 2013-10-04 13:23:16 UTC
Temporarily moving bugs to MODIFIED to work around errata tool bug

Comment 13 Nirupama Karandikar 2014-01-15 12:21:10 UTC
Tested with sssd-1.11.2-18.el7.x86_64

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: autofs15 - BZ 967636 SSSD frequently fails to return automount maps from LDAP
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   LOG    ] :: Duration: 26s
:: [   LOG    ] :: Assertions: 10 good, 0 bad
:: [   PASS   ] :: RESULT: autofs15 - BZ 967636 SSSD frequently fails to return automount maps from LDAP

Comment 14 Ludek Smid 2014-06-13 13:13:36 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.