Bug 967636 - SSSD frequently fails to return automount maps from LDAP
Summary: SSSD frequently fails to return automount maps from LDAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-27 17:46 UTC by Derek Warren
Modified: 2020-05-04 10:36 UTC (History)
8 users (show)

Fixed In Version: sssd-1.9.2-91.el6
Doc Type: Bug Fix
Doc Text:
Cause: The number of autofs maps returned from the SSSD to the automounter deamon was incorrect in some cases, especially with large automounter maps. Consequence: As a consequence, large automounter maps were not returned reliably to the automounter deamon. Fix: The number of maps returned was fixed to be correct in all cases. Result: Large automounter maps work reliably after the update.
Clone Of:
Environment:
Last Closed: 2013-11-21 22:18:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
FedoraHosted SSSD 1739 0 None None None Never
Github SSSD sssd issues 2781 0 None None None 2020-05-04 10:36:25 UTC
Red Hat Product Errata RHBA-2013:1680 0 normal SHIPPED_LIVE sssd bug fix and enhancement update 2013-11-20 21:52:37 UTC

Description Derek Warren 2013-05-27 17:46:54 UTC
Description of problem:
SSSD 1.9.2's autofs component frequently fails to read any automount maps in LDAP.

Version-Release number of selected component (if applicable):
1.9.2

How reproducible:
Very easily.

Steps to Reproduce:
1. Have lots of automount entries in an LDAP server (~250 in our case).
2. On an SSSD+autofs+LDAP client, run `automount --dumpmaps` 10 times.
3. Behold: you will only get automount maps from LDAP ~30% of the time.

Actual results:
Out of 10 attempts at running `automount --dumpmaps` only attempts #5, 6 and 8  returned automount information from LDAP.

Expected results:
automount --dumpmaps should always return a complete set of automount maps from  LDAP.


Additional info:
This has already been reported against
RHEL7: https://bugzilla.redhat.com/show_bug.cgi?id=891281
Fedora 18: https://bugzilla.redhat.com/show_bug.cgi?id=928447

The bug has already been fixed in SSSD 1.9.5:
https://fedorahosted.org/sssd/ticket/1739

This bug is basically a request for the fix to be backported to the base CentOS 6 SSSD package (1.9.2).

Relevant debug output is available in the above tickets.

Comment 2 Jakub Hrozek 2013-05-28 08:24:30 UTC
I agree we should fix this problem in RHEL6.5, too.

Here is a test package, it's the latest 6.4 plus that one patch. Would you mind trying it out?

http://jhrozek.fedorapeople.org/sssd-test-builds/autofs/

Comment 3 Derek Warren 2013-05-28 16:03:10 UTC
Thanks for looking at this and for the quick response.

I tested these packages on two CentOS 6.4 hosts and in both cases things look very good.  These hosts were using SSSD and Active Directory for authorization, automount maps, and UID/GID lookups. All existing functionality continued to work.

Let us know if there's anything else we can test for you.


Before:
[libsss_autofs-1.9.2-82.7.el6_4.x86_64, sssd-client-1.9.2-82.7.el6_4.x86_64]

# while :; do automount --dumpmaps | wc -l ; sleep 1 ; done
15
344
344
354
15
344
354
354
354
302
15
344
354
304
15
344
344
354
354
354
354
354
354
344
344
15
354
354
354



After:
[libsss_autofs-1.9.2-82.7.el6_4.1.x86_64, sssd-client-1.9.2-82.7.el6_4.1.x86_64]

# while :; do automount --dumpmaps | wc -l ; sleep 1 ; done
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333
333

Comment 4 Jakub Hrozek 2013-05-29 09:31:57 UTC
Thank you for testing, Derek!

Comment 5 Jakub Hrozek 2013-05-30 10:03:57 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1739

Comment 11 Nirupama Karandikar 2013-09-23 12:49:07 UTC
Output of beaker run with sssd-1.9.2-127.el6.x86_64


::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: autofs15 - BZ 967636 SSSD frequently fails to return automount maps from LDAP
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   PASS   ] :: Automount maps are consistant 
:: [   LOG    ] :: Duration: 25s
:: [   LOG    ] :: Assertions: 10 good, 0 bad
:: [   PASS   ] :: RESULT: autofs15 - BZ 967636 SSSD frequently fails to return automount maps from LDAP

Comment 12 errata-xmlrpc 2013-11-21 22:18:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1680.html


Note You need to log in before you can comment on or make changes to this bug.