Bug 891354 - Bluebird looks wierd on GTK3 apps (in Xfce)
Summary: Bluebird looks wierd on GTK3 apps (in Xfce)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluebird
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 969636 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-02 17:02 UTC by Miro Hrončok
Modified: 2013-09-06 05:20 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-09-01 22:58:57 UTC


Attachments (Terms of Use)
ABRT with Bluebird (44.52 KB, image/png)
2013-01-02 17:02 UTC, Miro Hrončok
no flags Details
ABRT with Greybird (43.41 KB, image/png)
2013-01-02 17:03 UTC, Miro Hrončok
no flags Details
Update to 0.6.2 (2.17 KB, patch)
2013-03-09 00:33 UTC, Othman Madjoudj
no flags Details | Diff
Bluebird on GTK3 on Fedora 19 (31.89 KB, image/png)
2013-07-02 20:15 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2013-01-02 17:02:10 UTC
Created attachment 671562 [details]
ABRT with Bluebird

Description of problem: When using Blueboird theme in Xfce, GTK3 apps look wierd.


Version-Release number of selected component (if applicable): 0.6-5.fc18


How reproducible: Tested only on 1 machine, but still present.


Steps to Reproduce:
1. Install latest Fedora 18 with Xfce
2. Set Bluebird theme
3. Open GTK3 application, such as ABRT
  
Actual results: The app looks wierd, like if the theme is not woking porpperly.


Expected results: The app should looks like an GTK2 app with the same theme.


Additional info: I suppose Bluebird and Greybird are very similar, only with different colors. Greybirds looks OK. Attaching both screenshots.

Comment 1 Miro Hrončok 2013-01-02 17:03:06 UTC
Created attachment 671563 [details]
ABRT with Greybird

Comment 2 Miro Hrončok 2013-03-07 23:33:21 UTC
If you just update the package from the last git commit, it should be OK.


Changing to Kevin, as it seems, he's maintaining it: https://admin.fedoraproject.org/pkgdb/acls/name/bluebird

Comment 3 Othman Madjoudj 2013-03-09 00:32:04 UTC
Bluebird version 0.6.2 should fix this issue, I asked once ochosi from shimmerproject (Greybird/Bluebird/Albatross authors) to tag each major update (eg: new Gtk release) to make packaging easier.

Miro, can you test with packages from this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5097449

pkgs: http://kojipkgs.fedoraproject.org//work/tasks/7450/5097450/

I've attached a patch so Jayson or Kevin can update the package, tarbal can be downloaded with:

wget --content-disposition https://github.com/shimmerproject/Bluebird/archive/v0.6.2.tar.gz

Comment 4 Othman Madjoudj 2013-03-09 00:33:08 UTC
Created attachment 707252 [details]
Update to 0.6.2

Comment 5 Miro Hrončok 2013-03-09 16:50:41 UTC
0.6.2 looks good (i.e. fixed) Thanks

Comment 6 Kevin Fenzi 2013-03-09 17:50:35 UTC
Athmane: Thanks! 

Any reason for: 

-Requires:       gtk-unico-engine >= 1.0.1
+#Requires:       gtk-unico-engine >= 1.0.1

?

Comment 7 Othman Madjoudj 2013-03-10 03:15:23 UTC
(In reply to comment #6)
> Any reason for: 
> 
> -Requires:       gtk-unico-engine >= 1.0.1
> +#Requires:       gtk-unico-engine >= 1.0.1


Newer Bluebird releases are based on Greybird, which does not require unico engine, it uses the default gtk3 engine.

Comment 8 Kevin Fenzi 2013-03-10 04:15:40 UTC
Right, better to just remove it. ;) 

Will push out an update now... thanks.

Comment 9 Fedora Update System 2013-03-10 04:29:36 UTC
bluebird-0.6.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluebird-0.6.2-1.fc18

Comment 10 Fedora Update System 2013-03-11 01:26:11 UTC
Package bluebird-0.6.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluebird-0.6.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3657/bluebird-0.6.2-1.fc18
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-04-01 03:23:41 UTC
bluebird-0.6.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Miro Hrončok 2013-07-02 20:14:49 UTC
This bug is again present in Fedora 19.

Comment 13 Miro Hrončok 2013-07-02 20:15:38 UTC
Created attachment 767933 [details]
Bluebird on GTK3 on Fedora 19

Comment 14 Miro Hrončok 2013-08-28 17:02:57 UTC
*** Bug 969636 has been marked as a duplicate of this bug. ***

Comment 15 Miro Hrončok 2013-08-28 17:07:00 UTC
Version 0.8 fixes this. I've requested ACLs, so I can update it by myself (I have it prepared).

Comment 16 Kevin Fenzi 2013-08-29 17:38:27 UTC
I've added you to acls... update away and thanks!

Comment 17 Fedora Update System 2013-08-30 11:11:01 UTC
bluebird-0.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/bluebird-0.8-1.fc19

Comment 18 Fedora Update System 2013-08-30 11:11:41 UTC
bluebird-0.8-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluebird-0.8-1.fc18

Comment 19 Fedora Update System 2013-08-30 22:56:26 UTC
Package bluebird-0.8-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluebird-0.8-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15549/bluebird-0.8-1.fc18
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2013-09-01 22:58:57 UTC
bluebird-0.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-09-06 05:20:44 UTC
bluebird-0.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.