This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 89202 - hwbrowser always crashed
hwbrowser always crashed
Status: CLOSED DUPLICATE of bug 74956
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-20 14:31 EDT by baulv
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cat /proc/pci and /var/log/dmsg plus the cruft from ~#hwbroser (13.83 KB, text/plain)
2003-04-20 14:33 EDT, baulv
no flags Details

  None (edit)
Description baulv 2003-04-20 14:31:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Description of problem:
the hwbrowser graphics starts up but ends abruptly after invoking 'hwbrowser' as
root


Version-Release number of selected component (if applicable):
hwbrowser-0.6-1

How reproducible:
Always

Steps to Reproduce:
1. su -
2. hwbrowser
3. ---pooof--- gone
    

Actual Results:  the program exited w/o an error message

Expected Results:  list all the hardware in a GUI.
my cutomized grey-wht color scheme or default 'blue-curve' has the same effect.


Additional info:


(DeviceList.py:3062): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:3062): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:3062): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20
[root@w4 root]# hwbrowser
Comment 1 baulv 2003-04-20 14:33:36 EDT
Created attachment 91198 [details]
cat /proc/pci and /var/log/dmsg plus the cruft from ~#hwbroser
Comment 2 Brent Fox 2003-04-21 15:08:57 EDT

*** This bug has been marked as a duplicate of 74956 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:52:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.