Bug 892626 - Double logging when using syslog
Summary: Double logging when using syslog
Status: CLOSED DUPLICATE of bug 966050
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: openstack-nova (Show other bugs)
(Show other bugs)
Version: el6
Hardware: Unspecified Unspecified
unspecified
low
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-07 12:49 UTC by robert.vanleeuwen
Modified: 2014-01-15 14:43 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 14:43:48 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (5.02 KB, patch)
2013-01-07 13:05 UTC, robert.vanleeuwen
no flags Details | Diff

Description robert.vanleeuwen 2013-01-07 12:49:25 UTC
Description of problem:
Doubled logging when configuring syslog: logging will go to syslog AND to file.

The initscripts of the various nova components include a --logfile $logfile
This will always turn on logging to file even if syslog is setup in the nova config.

FYI, Ubuntu upstart does not use a --logfile in the init script:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/quantal/nova/quantal/view/head:/debian/nova-api-os-compute.upstart.in


Version-Release number of selected component (if applicable):
Folsom

Comment 1 robert.vanleeuwen 2013-01-07 13:05:42 UTC
Created attachment 673991 [details]
Proposed patch

Comment 2 Pádraig Brady 2014-01-15 14:43:48 UTC

*** This bug has been marked as a duplicate of bug 966050 ***


Note You need to log in before you can comment on or make changes to this bug.