Bug 966050 - [RFE] Double logging when using syslog;
[RFE] Double logging when using syslog;
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
low Severity low
: rc
: 5.0 (RHEL 7)
Assigned To: Vladan Popovic
Ami Jeain
: FutureFeature, Triaged
: 892626 (view as bug list)
Depends On:
Blocks: 1083039 1083050 1083057 1083063
  Show dependency treegraph
 
Reported: 2013-05-22 07:09 EDT by robert.vanleeuwen
Modified: 2016-04-27 00:09 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-nova-2014.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
In the previous release, logging went to both syslog AND to file if syslog was enabled in the Compute configuration. This double logging was a result of the initscripts of the various components including a '--logfile $logfile'. The --logfile argument has now been removed from Compute service scripts and the default log file used. Logging is no longer doubled when syslog is enabled. Additionally, the default log files have been renamed to nova-{service_name}.log (for example, from {log_dir}/compute.log to {log_dir}/nova-compute.log).
Story Points: ---
Clone Of:
: 1083039 1083047 1083050 1083057 1083063 (view as bug list)
Environment:
Last Closed: 2014-07-08 11:26:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description robert.vanleeuwen 2013-05-22 07:09:26 EDT
Description of problem:
Double logging when using syslog; 

Doubled logging when configuring syslog: logging will go to syslog AND to file.

The initscripts of the various components include a --logfile $logfile
This will always turn on logging to file even if syslog is setup in the nova config.

Note that this bug is a duplicate of the bugreport in EPEL: https://bugzilla.redhat.com/show_bug.cgi?id=892626

I recreate this report since RDO is split of from the EPEL version (and that nothing happened with that bugreport)
Comment 1 Pádraig Brady 2014-01-15 09:43:48 EST
*** Bug 892626 has been marked as a duplicate of this bug. ***
Comment 2 Xavier Queralt 2014-03-10 09:38:28 EDT
I think there is no specify the logfile in the service script. Vladan, could you change this in the nova service scripts while doing the next build?
Comment 3 Alan Pevec 2014-04-01 06:15:02 EDT
(In reply to Xavier Queralt from comment #2)
> I think there is no specify the logfile in the service script.

--logfile is specified in each service script so they have separate log files.

> Vladan, could you change this in the nova service scripts while doing the next build?

If you want to remove --logfile, then each service will need separate dist-conf file?
Comment 4 Alan Pevec 2014-04-01 13:36:10 EDT
> If you want to remove --logfile, then each service will need separate
> dist-conf file?

Answering to myself: not needed, if log_dir is set (and it is in nova-dist.conf), log_file not set, default logfile will be take from the binary filename (see _get_binary_name and _get_log_file_path in oslo log.py)
Comment 9 errata-xmlrpc 2014-07-08 11:26:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0853.html

Note You need to log in before you can comment on or make changes to this bug.