Bug 89269 - Deleting a workflow causes a CMS Error
Deleting a workflow causes a CMS Error
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity high
: ---
: ---
Assigned To: Justin Ross
Jon Orris
:
: 88969 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-21 21:43 EDT by Jon Orris
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 16:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-04-21 21:43:47 EDT
Description of problem:

@30010/RHDB

Select a workflow.
Delete it.
Get CCM Error.

This happens at the end of WorkflowSmokeTest. The workflow has a number of tasks
defined.


An unexpected error has occurred. If this continues to be a problem for you
please contact the administrators of the site quoting the following:

CCM issue report code: ccm-installer.boston.redhat.com:8080:494d777c:f4b2cfe5a5


-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code:
ccm-installer.boston.redhat.com:8080:494d777c:f4b2cfe5a5 -*-*-*-
-*-*-*- Message: Error executing SQL: 
delete from cw_processes
where process_id=?
Occurred while:
    Deleting information for [com.arsdigita.workflow.simple.Workflow:{id=24101}]
(root cause: ERROR:  process_def_id_fk referential integrity violation - key in
cw_processes still referenced from cw_process_definitions
) -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/x-shockwave-flash, */*
accept-encoding: gzip, deflate
accept-language: en-us
cache-control: no-cache
connection: Keep-Alive
content-length: 356
content-type: application/x-www-form-urlencoded
cookie: JSESSIONID=32736B20E123BAD3DD0C9A9F5A221883;
ad_user_login=16059!1050973010228!625ceUVyyMi0ykdyJRZdjw==
host: ccm-installer.boston.redhat.com:8080
referer:
http://ccm-installer.boston.redhat.com:8080/ccm/articles/admin/index.jsp?bbp.803.d=asc&bbp.511.sel=24101&bbp.356.stack=6&bbp.s=403&bbp.i=1f7k6rumnlnjxha7clffxymi3mo5g1lst2j5m2mvoaz22fqxwhzwb92zai2y0jsao71cksj2pqm4sn0jv361v8f235rthegsne6hdh72aeoudlplcdip16igzv8l51rt2s0eanzrtqxok959vckaagg&bbp.3.pane=3&bbp.4.folder=13001&bbp.66.sel=1&bbp.407.col=0&bbp.62.ps=20&g11n.enc=ISO-8859-1
user-agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: 32736B20E123BAD3DD0C9A9F5A221883 (expires: -1)
ad_user_login: 16059!1050973010228!625ceUVyyMi0ykdyJRZdjw== (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.persistence.PersistenceException: Error executing SQL: 
delete from cw_processes
where process_id=?
Occurred while:
    Deleting information for [com.arsdigita.workflow.simple.Workflow:{id=24101}]
(root cause: java.sql.SQLException: ERROR:  process_def_id_fk referential
integrity violation - key in cw_processes still referenced from
cw_process_definitions
)
	at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:128)
	at com.arsdigita.persistence.DataStore.fireOperation(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.fireEvent(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.fireEvent(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.doDelete(DataStore.java:739)
	at com.arsdigita.persistence.GenericDataObject.doDelete(GenericDataObject.java:831)
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java:40)
	at com.arsdigita.persistence.GenericDataObject.delete(GenericDataObject.java:382)
	at com.arsdigita.domain.DomainObject.delete(DomainObject.java:323)
	at com.arsdigita.workflow.simple.Task.delete(Task.java:1162)
	at com.arsdigita.workflow.simple.Workflow.delete(Workflow.java:213)
	at
com.arsdigita.cms.ui.workflow.WorkflowDeleteForm.process(WorkflowDeleteForm.java:58)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:444)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:418)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:246)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:254)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:257)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:337)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:135)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:683)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:431)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:355)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:247)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:243)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:190)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2347)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:180)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:170)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:170)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:468)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:174)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:1027)
	at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1125)
	at java.lang.Thread.run(Thread.java:512)
Root cause: 
java.sql.SQLException: ERROR:  process_def_id_fk referential integrity violation
- key in cw_processes still referenced from cw_process_definitions

	at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java(Compiled Code))
	at org.postgresql.jdbc2.Statement.execute(Statement.java(Compiled Code))
	at org.postgresql.jdbc2.Statement.execute(Statement.java(Compiled Code))
	at
org.postgresql.jdbc2.PreparedStatement.execute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.db.PreparedStatement.doExecute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.db.PreparedStatement.execute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.persistence.DataStore.fireOperation(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.fireEvent(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.fireEvent(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.doDelete(DataStore.java:739)
	at com.arsdigita.persistence.GenericDataObject.doDelete(GenericDataObject.java:831)
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java:40)
	at com.arsdigita.persistence.GenericDataObject.delete(GenericDataObject.java:382)
	at com.arsdigita.domain.DomainObject.delete(DomainObject.java:323)
	at com.arsdigita.workflow.simple.Task.delete(Task.java:1162)
	at com.arsdigita.workflow.simple.Workflow.delete(Workflow.java:213)
	at
com.arsdigita.cms.ui.workflow.WorkflowDeleteForm.process(WorkflowDeleteForm.java:58)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:444)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:418)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:246)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:254)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:257)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:337)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:135)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:683)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:431)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:355)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:247)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:243)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:190)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2347)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:180)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:170)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:170)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:468)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:174)
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:1027)
	at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1125)
	at java.lang.Thread.run(Thread.java:512)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/articles/admin/index.jsp
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: System properties -*-*-*-
catalina.base: /usr/share/tomcat
catalina.home: /usr/share/tomcat
catalina.useNaming: true
file.encoding: ISO-8859-1
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
/opt/IBMJava2-131/lib/tools.jar:/var/www/ccm-cms/dist/WEB-INF/lib/jaas.jar:/var/www/ccm-cms/dist/WEB-INF/lib/jce.jar:/var/www/ccm-cms/dist/WEB-INF/lib/sunjce_provider.jar:/var/www/ccm-cms/dist/WEB-INF/lib/xerces.jar:/var/www/ccm-cms/dist/WEB-INF/lib/xalan.jar:/opt/oracle/product/jdbc/lib/classes12.zip:/opt/IBMJava2-131/lib/tools.jar:/usr/share/tomcat/bin/bootstrap.jar
java.class.version: 46.0
java.compiler: jitc
java.endorsed.dirs: /usr/share/tomcat/bin:/usr/share/tomcat/common/lib
java.ext.dirs: /opt/IBMJava2-131/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20020622 (JIT enabled: jitc)
java.home: /opt/IBMJava2-131/jre
java.io.tmpdir: /usr/share/tomcat/temp
java.library.path:
/opt/IBMJava2-131/jre/bin:/opt/IBMJava2-131/jre/bin/classic:/opt/oracle/product/lib:/lib:/usr/lib:/usr/local/lib:/usr/lib
java.naming.factory.initial: org.apache.naming.java.javaURLContextFactory
java.naming.factory.url.pkgs: org.apache.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20020622 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory: org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
org.apache.xalan.processor.TransformerFactoryImpl
line.separator: 

org.xml.sax.driver: org.apache.xerces.parsers.SAXParser
os.arch: x86
os.name: Linux
os.version: 2.4.9-e.12
path.separator: :
PreferredXSLTTransformer: XALAN
sun.boot.class.path:
/opt/IBMJava2-131/jre/lib/rt.jar:/opt/IBMJava2-131/jre/lib/i18n.jar:/opt/IBMJava2-131/jre/classes
sun.boot.library.path: /opt/IBMJava2-131/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /var/lib/tomcat
user.home: /var/lib/tomcat
user.language: en
user.name: tomcat
user.region: US
user.timezone: America/New_York
vendor: Apache Software Foundation
vendor-url: http://xml.apache.org/xalan
version: 2.1.0
-*-*-*-*-*- End Error Report -*-*-*-*-*-
Comment 1 Justin Ross 2003-04-23 10:56:27 EDT
Fixed in perforce change 30083.
Comment 2 Justin Ross 2003-04-23 11:13:57 EDT
*** Bug 88969 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.