Bug 892765 - virt-manager needs to store Guest Image & Guest Settings in Home folder by Default
virt-manager needs to store Guest Image & Guest Settings in Home folder by De...
Status: CLOSED DUPLICATE of bug 557103
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 14:04 EST by Moez Roy
Modified: 2013-04-08 16:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-01 06:04:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-01-07 14:04:55 EST
virt-manager needs to store Guest Image & Guest Settings in Home folder

Like how VirtualBox does by default:

/home/*username*/VirtualBox VMs

Inside folder 'VirtualBox VMs' there is Guest Image and Guest Settings.

This makes it easier for backup.

Example, when upgrading to Fedora 18, I just backed up my Home Folder.

Then if I need to use a Guest OS, I only need to copy the Guest OS folder from my backup into the "clean install" of Fedora 18.

Then I just click Add Machine in VirtualBox manager ==> Machine ==> Add (CTRL + A) and point it to the .vbox file which has the Guest OS settings and also states that the .vdi image is located in same folder.
Comment 1 Cole Robinson 2013-04-01 06:04:23 EDT
This really requires using qemu:///session, which we may never do by default, but we need to improve support for.

*** This bug has been marked as a duplicate of bug 557103 ***
Comment 2 Moez Roy 2013-04-05 22:03:24 EDT
Why would I want to run a qemu session which I believe is a software only virtualization? 

Why not KVM?

I really need to keep my virtual images on a separate hard-drive from OS.
Comment 3 Cole Robinson 2013-04-08 16:41:55 EDT
qemu:///session uses KVM so you should see comparable speeds

Note You need to log in before you can comment on or make changes to this bug.