Bug 89285 - Unable to add RHN applet to panel after removing
Unable to add RHN applet to panel after removing
Status: CLOSED DUPLICATE of bug 76901
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 03:21 EDT by Dee-Ann LeBlanc
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dee-Ann LeBlanc 2003-04-22 03:21:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Due to user error, the RHN monitor applet got removed from my panel. Trying to
add it back has proven fruitless, though it might be that the applet _IS_
starting but is showing at 1 pixel, which I see is mentioned in an earlier bug
report regarding RHL 8. I've tried the following solutions:

1. Main Menu -> System Tools -> Red Hat Network Alert Icon

I run it, nothing seems to happen, though it does produce item 13324 as shown below:

[dee@localhost dee]$ ps aux | grep rhn
root      3787  0.0  0.0  3404  428 ?        S    Apr19   0:00 rhnsd --interval
240
dee      13324  3.0  1.3 24212 13408 ?       S    00:16   0:00 /usr/bin/python
/usr/bin/rhn-applet-gui
dee      13326  0.0  0.0  3576  640 pts/0    S    00:16   0:00 grep rhn

Now, if I log out and back in, checking the "keep current settings" on the way
out, it shows the RHN applet starting in the splash window but no applet on the
panel, and again I would see it in the process listing. 

2. I also tried:

rhn-applet-gui &

Nothing shows up, but (I killed the previous process so you won't see it again)
I do have:

[dee@localhost dee]$ ps aux | grep rhn
root      3787  0.0  0.0  3404  428 ?        S    Apr19   0:00 rhnsd --interval240
dee      13327  5.5  1.3 24220 13416 pts/0   S    00:18   0:00 /usr/bin/python /
usr/bin/rhn-applet-gui
dee      13329  0.0  0.0  3576  640 pts/0    S    00:18   0:00 grep rhn

So ... my guess is maybe it's showing up at a single pixel? I don't know, I even
wiped out all of the applets and icons on that part of my panel and it just
stays blank. 

Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-0.9.0.1

How reproducible:
Always

Steps to Reproduce:
1. Remove RHN panel applet.
2. Try to restore with Main Menu -> System Tools -> Red Hat Network Alert Icon
3. 

See detailed discussion above.
    

Actual Results:  Nothing, but the process shows up in the process list. 

See detailed discussion above.

Expected Results:  The RHN panel applet should have appeared on my panel. I'd
really like it back, please. :)

Additional info:

The icon was showing blue with the checkmark when it got deleted. I'm fully up
to date as of around midnight Pacific, April 22.
Comment 1 Daniel Veillard 2003-04-22 03:50:10 EDT
Seems to be a duplicate of bug 76901.
It is a rendering bug, apparently in the eggtray module.
I'm unable to reproduce it myself, stopping the applet and restarting
it works as expected, I have no idea how and why the display is been
corrupted. The applet seems to work though, but doesn't show up correctly
due to a container bug apparently. Since it seems to be a problem persisting
over sessions, maybe discarding the preferences in ~/.gnome can fix the
problem, but that doesn't sound right anyway.

Daniel

*** This bug has been marked as a duplicate of 76901 ***
Comment 2 Dee-Ann LeBlanc 2003-04-22 21:09:49 EDT
The applet is useless if I can't see the icon telling me if I need to grab an
update, so saying it works even though the icon isn't showing really isn't an
answer. Which preferences in ~/.gnome would you recommend deleting? I don't see
anything in there that looks like it deals particularly with rhn, and I don't
feel like just randomly deleting things on my main machine. :) But I'm willing
to try some things out to get this sucker fixed.
Comment 3 Daniel Veillard 2003-04-23 03:58:59 EDT
Okay, I meant "the code of the applet seems to work", the fact that
it doesn't render and hence is not useful seems to be related to another
program/library .
For ~/.gnome , no idea where the configuration might be stored,
so try to logout, login in a text console, do mv ~/.gnome ~/.gnome.bak
go back through the graphical login and see if the applet rendering
problem is corrected, then log out again, go back to the text console,
rm -rf  ~/.gnome and mv ~/.gnome.bak ~/.gnome to restore your preferences.

Daniel
Comment 4 Dee-Ann LeBlanc 2003-04-23 12:22:13 EDT
Moving ~/.gnome has absolutely no effect. Now, moving ~/.gnome2 takes away all
the panel icons, so I thought that was the answer, but no, the RHN applet icon
still wouldn't show up even though it started by default.
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.